summaryrefslogtreecommitdiffstats
path: root/python/python3/patches/python3.no-static-library.diff
diff options
context:
space:
mode:
author Audrius Kažukauskas2015-03-01 21:20:28 +0100
committer Willy Sudiarto Raharjo2015-03-08 00:35:07 +0100
commit488a866d870abcaa6cf1aa1b165136a20361fabc (patch)
tree5a2c423bde2329e93b138d25ee5211c6a2bde274 /python/python3/patches/python3.no-static-library.diff
parente7f9c311f6a69fd909fab4c2c641fd3b3e8f05e7 (diff)
downloadslackbuilds-488a866d870abcaa6cf1aa1b165136a20361fabc.tar.gz
python/python3: Updated for version 3.4.3.
Signed-off-by: Audrius Kažukauskas <audrius@neutrino.lt>
Diffstat (limited to 'python/python3/patches/python3.no-static-library.diff')
-rw-r--r--python/python3/patches/python3.no-static-library.diff14
1 files changed, 7 insertions, 7 deletions
diff --git a/python/python3/patches/python3.no-static-library.diff b/python/python3/patches/python3.no-static-library.diff
index 442373021c..fa3a36b9d5 100644
--- a/python/python3/patches/python3.no-static-library.diff
+++ b/python/python3/patches/python3.no-static-library.diff
@@ -1,7 +1,7 @@
-diff -uar Python-3.4.2.orig/Makefile.pre.in Python-3.4.2/Makefile.pre.in
---- Python-3.4.2.orig/Makefile.pre.in 2014-10-08 11:18:14.000000000 +0300
-+++ Python-3.4.2/Makefile.pre.in 2014-10-09 21:12:08.504150485 +0300
-@@ -537,7 +537,7 @@
+diff -uar Python-3.4.3.orig/Makefile.pre.in Python-3.4.3/Makefile.pre.in
+--- Python-3.4.3.orig/Makefile.pre.in 2015-02-25 13:27:45.000000000 +0200
++++ Python-3.4.3/Makefile.pre.in 2015-02-25 21:29:01.322056319 +0200
+@@ -538,7 +538,7 @@
$(RUNSHARED) $(PYTHON_FOR_BUILD) ./Tools/clinic/clinic.py --make
# Build the interpreter
@@ -10,7 +10,7 @@ diff -uar Python-3.4.2.orig/Makefile.pre.in Python-3.4.2/Makefile.pre.in
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Modules/python.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
platform: $(BUILDPYTHON) pybuilddir.txt
-@@ -572,18 +572,6 @@
+@@ -573,18 +573,6 @@
_TCLTK_INCLUDES='$(TCLTK_INCLUDES)' _TCLTK_LIBS='$(TCLTK_LIBS)' \
$(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
@@ -29,7 +29,7 @@ diff -uar Python-3.4.2.orig/Makefile.pre.in Python-3.4.2/Makefile.pre.in
libpython$(LDVERSION).so: $(LIBRARY_OBJS)
if test $(INSTSONAME) != $(LDLIBRARY); then \
$(BLDSHARED) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
-@@ -673,7 +661,7 @@
+@@ -674,7 +662,7 @@
echo "-----------------------------------------------"; \
fi
@@ -38,7 +38,7 @@ diff -uar Python-3.4.2.orig/Makefile.pre.in Python-3.4.2/Makefile.pre.in
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Modules/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
############################################################################
-@@ -1324,18 +1312,6 @@
+@@ -1325,18 +1313,6 @@
else true; \
fi; \
done