summaryrefslogtreecommitdiffstats
path: root/python/python3/patches/python3.no-static-library.diff
diff options
context:
space:
mode:
author Audrius Kažukauskas2016-12-28 15:46:00 +0100
committer Willy Sudiarto Raharjo2016-12-31 02:22:44 +0100
commite0f817d0c0402871586b88ec6cde58ef0e16e7bb (patch)
treed84e2cdc8f1b73e90c2f7d5db9c706a90ad9d188 /python/python3/patches/python3.no-static-library.diff
parent51a755c3ac576163f75698baab6c2ee22298578b (diff)
downloadslackbuilds-e0f817d0c0402871586b88ec6cde58ef0e16e7bb.tar.gz
python/python3: Updated for version 3.6.0.
Signed-off-by: Audrius Kažukauskas <audrius@neutrino.lt>
Diffstat (limited to 'python/python3/patches/python3.no-static-library.diff')
-rw-r--r--python/python3/patches/python3.no-static-library.diff16
1 files changed, 8 insertions, 8 deletions
diff --git a/python/python3/patches/python3.no-static-library.diff b/python/python3/patches/python3.no-static-library.diff
index c33aeedcf7..2821ca79d0 100644
--- a/python/python3/patches/python3.no-static-library.diff
+++ b/python/python3/patches/python3.no-static-library.diff
@@ -1,6 +1,6 @@
-diff -uar Python-3.5.1.orig/Makefile.pre.in Python-3.5.1/Makefile.pre.in
---- Python-3.5.1.orig/Makefile.pre.in 2015-12-07 03:39:09.000000000 +0200
-+++ Python-3.5.1/Makefile.pre.in 2015-12-14 21:25:22.103542432 +0200
+diff -uar Python-3.6.0.orig/Makefile.pre.in Python-3.6.0/Makefile.pre.in
+--- Python-3.6.0.orig/Makefile.pre.in 2016-12-23 04:21:21.000000000 +0200
++++ Python-3.6.0/Makefile.pre.in 2016-12-27 22:50:14.139741226 +0200
@@ -564,7 +564,7 @@
$(RUNSHARED) $(PYTHON_FOR_BUILD) ./Tools/clinic/clinic.py --make
@@ -10,10 +10,10 @@ diff -uar Python-3.5.1.orig/Makefile.pre.in Python-3.5.1/Makefile.pre.in
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/python.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
platform: $(BUILDPYTHON) pybuilddir.txt
-@@ -599,18 +599,6 @@
- _TCLTK_INCLUDES='$(TCLTK_INCLUDES)' _TCLTK_LIBS='$(TCLTK_LIBS)' \
+@@ -609,18 +609,6 @@
$(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
+
-# Build static library
-# avoid long command lines, same as LIBRARY_OBJS
-$(LIBRARY): $(LIBRARY_OBJS)
@@ -22,14 +22,14 @@ diff -uar Python-3.5.1.orig/Makefile.pre.in Python-3.5.1/Makefile.pre.in
- $(AR) $(ARFLAGS) $@ $(PARSER_OBJS)
- $(AR) $(ARFLAGS) $@ $(OBJECT_OBJS)
- $(AR) $(ARFLAGS) $@ $(PYTHON_OBJS) Python/frozen.o
-- $(AR) $(ARFLAGS) $@ $(MODULE_OBJS) $(SIGNAL_OBJS)
+- $(AR) $(ARFLAGS) $@ $(MODULE_OBJS)
- $(AR) $(ARFLAGS) $@ $(MODOBJS)
- $(RANLIB) $@
-
libpython$(LDVERSION).so: $(LIBRARY_OBJS)
if test $(INSTSONAME) != $(LDLIBRARY); then \
$(BLDSHARED) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
-@@ -700,7 +688,7 @@
+@@ -710,7 +698,7 @@
echo "-----------------------------------------------"; \
fi
@@ -38,7 +38,7 @@ diff -uar Python-3.5.1.orig/Makefile.pre.in Python-3.5.1/Makefile.pre.in
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
############################################################################
-@@ -1372,18 +1360,6 @@
+@@ -1388,18 +1376,6 @@
else true; \
fi; \
done