summaryrefslogtreecommitdiffstats
path: root/python/python3-turbogears2
diff options
context:
space:
mode:
author Arn02022-03-08 22:54:37 +0100
committer Willy Sudiarto Raharjo2022-03-09 03:43:24 +0100
commit419db94fb3a41921b7f73cf683457ddd297c1399 (patch)
tree5b222b0ce8d58c14bd22bc29dcb3410f3b726a08 /python/python3-turbogears2
parent50e4a5c313bd42792f1831b025ecdc6314832d5f (diff)
downloadslackbuilds-419db94fb3a41921b7f73cf683457ddd297c1399.tar.gz
python/python3-turbogears2: renamed from TurboGears2 for python3, updated for version 2.4.3
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-turbogears2')
-rw-r--r--python/python3-turbogears2/README7
-rw-r--r--python/python3-turbogears2/python3-turbogears2.SlackBuild77
-rw-r--r--python/python3-turbogears2/python3-turbogears2.info10
-rw-r--r--python/python3-turbogears2/slack-desc19
4 files changed, 113 insertions, 0 deletions
diff --git a/python/python3-turbogears2/README b/python/python3-turbogears2/README
new file mode 100644
index 0000000000..65e373c5aa
--- /dev/null
+++ b/python/python3-turbogears2/README
@@ -0,0 +1,7 @@
+The Web Framework that scales with you.
+
+TurboGears 2 is built on top of the experience of several next
+generation web frameworks including TurboGears 1 (of course), Django,
+and Rails.
+All of these frameworks had limitations that frustrated us, and TG2 was
+built as an answer to that frustration.
diff --git a/python/python3-turbogears2/python3-turbogears2.SlackBuild b/python/python3-turbogears2/python3-turbogears2.SlackBuild
new file mode 100644
index 0000000000..00c6411a21
--- /dev/null
+++ b/python/python3-turbogears2/python3-turbogears2.SlackBuild
@@ -0,0 +1,77 @@
+#!/bin/bash
+
+# SlackBuild script for TurboGears2.
+# Yth | Pont-en-Royans, France | yth@ythogtha.org
+
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-turbogears2
+SRCNAM=TurboGears2
+VERSION=${VERSION:-2.4.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-turbogears2/python3-turbogears2.info b/python/python3-turbogears2/python3-turbogears2.info
new file mode 100644
index 0000000000..9ecab7896d
--- /dev/null
+++ b/python/python3-turbogears2/python3-turbogears2.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-turbogears2"
+VERSION="2.4.3"
+HOMEPAGE="http://www.turbogears.org/"
+DOWNLOAD="https://pypi.python.org/packages/source/T/TurboGears2/TurboGears2-2.4.3.tar.gz"
+MD5SUM="6f9621edadff3dbc055d9daae893357e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-crank python3-repoze.lru python3-webob"
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/python3-turbogears2/slack-desc b/python/python3-turbogears2/slack-desc
new file mode 100644
index 0000000000..5407ffe1a0
--- /dev/null
+++ b/python/python3-turbogears2/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-turbogears2: python3-TurboGears2 (Web Framework)
+python3-turbogears2:
+python3-turbogears2: TurboGears 2 is built on top of the experience of several next
+python3-turbogears2: generation web frameworks including TurboGears 1 (of course), Django,
+python3-turbogears2: and Rails.
+python3-turbogears2:
+python3-turbogears2: All of these frameworks had limitations that frustrated us, and TG2
+python3-turbogears2: was built as an answer to that frustration.
+python3-turbogears2:
+python3-turbogears2:
+python3-turbogears2: