summaryrefslogtreecommitdiffstats
path: root/python/python3-texttable
diff options
context:
space:
mode:
author fourtysixandtwo2023-10-08 18:06:59 +0200
committer Willy Sudiarto Raharjo2023-10-14 05:32:30 +0200
commit3a643c73d0173cf34c920108b52adf7eb85164d0 (patch)
tree2567c208e0cca9a829b505aa58194ab0d207216e /python/python3-texttable
parent1f33e1c2715ed6d151390d1b3530daead4170866 (diff)
downloadslackbuilds-3a643c73d0173cf34c920108b52adf7eb85164d0.tar.gz
python/python3-texttable: Updated for version 1.7.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-texttable')
-rw-r--r--python/python3-texttable/python3-texttable.SlackBuild25
-rw-r--r--python/python3-texttable/python3-texttable.info6
2 files changed, 7 insertions, 24 deletions
diff --git a/python/python3-texttable/python3-texttable.SlackBuild b/python/python3-texttable/python3-texttable.SlackBuild
index 757493cadb..ea7c9ef873 100644
--- a/python/python3-texttable/python3-texttable.SlackBuild
+++ b/python/python3-texttable/python3-texttable.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-texttable
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-texttable
SRCNAM=${PRGNAM#python3-*}
-VERSION=${VERSION:-1.6.7}
+VERSION=${VERSION:-1.7.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -51,20 +48,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -76,9 +59,9 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python3 setup.py install --root=$PKG
diff --git a/python/python3-texttable/python3-texttable.info b/python/python3-texttable/python3-texttable.info
index 189f891bdf..3983f4f1cb 100644
--- a/python/python3-texttable/python3-texttable.info
+++ b/python/python3-texttable/python3-texttable.info
@@ -1,8 +1,8 @@
PRGNAM="python3-texttable"
-VERSION="1.6.7"
+VERSION="1.7.0"
HOMEPAGE="https://github.com/foutaise/texttable"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/t/texttable/texttable-1.6.7.tar.gz"
-MD5SUM="83eb15fb541dd857ff051a8d0c979b9c"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/t/texttable/texttable-1.7.0.tar.gz"
+MD5SUM="e5d380c04fab132ccf0bbfd4f761bd51"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""