summaryrefslogtreecommitdiffstats
path: root/python/python3-setuptools_scm_git_archive
diff options
context:
space:
mode:
author Arn02022-03-08 23:46:43 +0100
committer Willy Sudiarto Raharjo2022-03-09 06:35:19 +0100
commit59b1b32dd38032b23fc27c841107b6797fc3fe44 (patch)
treed47dbd41b690d668d4813ff6f827aa1c095d7bde /python/python3-setuptools_scm_git_archive
parent0018c5a373468abfdf4e7774b5d0467513b75075 (diff)
downloadslackbuilds-59b1b32dd38032b23fc27c841107b6797fc3fe44.tar.gz
python/python3-setuptools_scm_git_archive: added, requirement for Kallithea
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-setuptools_scm_git_archive')
-rw-r--r--python/python3-setuptools_scm_git_archive/README5
-rw-r--r--python/python3-setuptools_scm_git_archive/python3-setuptools_scm_git_archive.SlackBuild77
-rw-r--r--python/python3-setuptools_scm_git_archive/python3-setuptools_scm_git_archive.info10
-rw-r--r--python/python3-setuptools_scm_git_archive/slack-desc19
4 files changed, 111 insertions, 0 deletions
diff --git a/python/python3-setuptools_scm_git_archive/README b/python/python3-setuptools_scm_git_archive/README
new file mode 100644
index 0000000000..3b39308c01
--- /dev/null
+++ b/python/python3-setuptools_scm_git_archive/README
@@ -0,0 +1,5 @@
+This is a setuptools_scm plugin that adds support for git archives,
+for example the ones GitHub automatically generates.
+
+Note that it only works for archives of tagged commits, because git
+currently lacks a format option equivalent to git describe --tags.
diff --git a/python/python3-setuptools_scm_git_archive/python3-setuptools_scm_git_archive.SlackBuild b/python/python3-setuptools_scm_git_archive/python3-setuptools_scm_git_archive.SlackBuild
new file mode 100644
index 0000000000..2d42d0d8a3
--- /dev/null
+++ b/python/python3-setuptools_scm_git_archive/python3-setuptools_scm_git_archive.SlackBuild
@@ -0,0 +1,77 @@
+#!/bin/bash
+
+# SlackBuild script for python3-setuptools_scm_git_archive.
+# Yth | Pont-en-Royans, France | yth@ythogtha.org
+
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-setuptools_scm_git_archive
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-1.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-setuptools_scm_git_archive/python3-setuptools_scm_git_archive.info b/python/python3-setuptools_scm_git_archive/python3-setuptools_scm_git_archive.info
new file mode 100644
index 0000000000..0794fb2e15
--- /dev/null
+++ b/python/python3-setuptools_scm_git_archive/python3-setuptools_scm_git_archive.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-setuptools_scm_git_archive"
+VERSION="1.1"
+HOMEPAGE="https://github.com/Changaco/setuptools_scm_git_archive/"
+DOWNLOAD="https://pypi.python.org/packages/source/s/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1.tar.gz"
+MD5SUM="1c9351fa5cebd12e76488737a7c78f2e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/python3-setuptools_scm_git_archive/slack-desc b/python/python3-setuptools_scm_git_archive/slack-desc
new file mode 100644
index 0000000000..f9dadcc9ee
--- /dev/null
+++ b/python/python3-setuptools_scm_git_archive/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-setuptools_scm_git_archive: python3-setuptools_scm_git_archive (scm plugin)
+python3-setuptools_scm_git_archive:
+python3-setuptools_scm_git_archive: This is a setuptools_scm plugin that adds support for git archives
+python3-setuptools_scm_git_archive: For example the ones GitHub automatically generates
+python3-setuptools_scm_git_archive:
+python3-setuptools_scm_git_archive:
+python3-setuptools_scm_git_archive:
+python3-setuptools_scm_git_archive:
+python3-setuptools_scm_git_archive: https://github.com/Changaco/setuptools_scm_git_archive/
+python3-setuptools_scm_git_archive:
+python3-setuptools_scm_git_archive: