summaryrefslogtreecommitdiffstats
path: root/python/python3-service-identity
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2022-03-31 12:22:31 +0200
committer Willy Sudiarto Raharjo2022-04-02 13:18:56 +0200
commite2483d234ee22e3150cfc466bc9c7ff8d73abfee (patch)
tree3015e9faa0b7cf526fc989fcd4230f4a1a61fe26 /python/python3-service-identity
parentca4bff1aa82263592493a287197ce214f7586f6a (diff)
downloadslackbuilds-e2483d234ee22e3150cfc466bc9c7ff8d73abfee.tar.gz
python/python3-service-identity: Added (SIV for PyOpenSSL).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-service-identity')
-rw-r--r--python/python3-service-identity/README6
-rw-r--r--python/python3-service-identity/python3-service-identity.SlackBuild98
-rw-r--r--python/python3-service-identity/python3-service-identity.info10
-rw-r--r--python/python3-service-identity/slack-desc19
4 files changed, 133 insertions, 0 deletions
diff --git a/python/python3-service-identity/README b/python/python3-service-identity/README
new file mode 100644
index 0000000000..68101d4809
--- /dev/null
+++ b/python/python3-service-identity/README
@@ -0,0 +1,6 @@
+Use this package if you use pyOpenSSL and don't want to be MITMed.
+service-identity aspires to give you all the tools you need for
+verifying whether a certificate is valid for the intended purposes.
+In the simplest case, this means host name verification. However,
+service-identity implements RFC 6125 fully and plans to add other
+relevant RFCs too.
diff --git a/python/python3-service-identity/python3-service-identity.SlackBuild b/python/python3-service-identity/python3-service-identity.SlackBuild
new file mode 100644
index 0000000000..451c124edd
--- /dev/null
+++ b/python/python3-service-identity/python3-service-identity.SlackBuild
@@ -0,0 +1,98 @@
+#!/bin/bash
+
+# Slackware build script for python3-service-identity
+#
+# Copyright 2021 Yth | Pont-en-Royans, France | yth@ythogtha.org
+# Based on 14.2 python2 python/service_identity slackbuild by:
+# Copyright 2014-2018 Markus Reichelt, Aachen, DE
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-service-identity
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-21.1.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a docs $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-service-identity/python3-service-identity.info b/python/python3-service-identity/python3-service-identity.info
new file mode 100644
index 0000000000..ebb26380dc
--- /dev/null
+++ b/python/python3-service-identity/python3-service-identity.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-service-identity"
+VERSION="21.1.0"
+HOMEPAGE="https://pypi.python.org/pypi/service-identity"
+DOWNLOAD="https://pypi.python.org/packages/source/s/service-identity/service-identity-21.1.0.tar.gz"
+MD5SUM="5e5c195d8fcedc72f9068be2ad9b5a13"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-attrs cryptography pyasn1-modules"
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/python3-service-identity/slack-desc b/python/python3-service-identity/slack-desc
new file mode 100644
index 0000000000..bd3a32f417
--- /dev/null
+++ b/python/python3-service-identity/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-service-identity: python3-service-identity (Service Identity Verification for pyOpenSSL)
+python3-service-identity:
+python3-service-identity: service-identity aspires to give you all the tools you need for
+python3-service-identity: verifying whether a certificate is valid for the intended purposes.
+python3-service-identity:
+python3-service-identity: service-identity implements RFC 6125 fully.
+python3-service-identity:
+python3-service-identity: https://pypi.python.org/project/service-identity
+python3-service-identity:
+python3-service-identity:
+python3-service-identity: