summaryrefslogtreecommitdiffstats
path: root/python/python3-pickleshare
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2017-04-16 13:01:20 +0200
committer Willy Sudiarto Raharjo2017-04-16 13:01:20 +0200
commit8ae285310e0a66b1e60527601316c968e5af1911 (patch)
tree7bfbcfa6164aec01fd09ab46d0fd84993fb94833 /python/python3-pickleshare
parent99980b018565f84d8099e6c9106eaae60cb4f929 (diff)
downloadslackbuilds-8ae285310e0a66b1e60527601316c968e5af1911.tar.gz
python/python3-pickleshare: Added (FS-based database for Python 3).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-pickleshare')
-rw-r--r--python/python3-pickleshare/README9
-rw-r--r--python/python3-pickleshare/python3-pickleshare.SlackBuild86
-rw-r--r--python/python3-pickleshare/python3-pickleshare.info10
-rw-r--r--python/python3-pickleshare/slack-desc19
4 files changed, 124 insertions, 0 deletions
diff --git a/python/python3-pickleshare/README b/python/python3-pickleshare/README
new file mode 100644
index 0000000000..c7c034a911
--- /dev/null
+++ b/python/python3-pickleshare/README
@@ -0,0 +1,9 @@
+PickleShare is a small shelve-like datastore with concurrency support.
+
+Like shelve, a PickleShareDB object acts like a normal dictionary. Unlike
+shelve, many processes can access the database simultaneously. Changing a value
+in database is immediately visible to other processes accessing the same
+database.
+
+Concurrency is possible because the values are stored in separate files. Hence
+the "database" is a directory where all files are governed by PickleShare.
diff --git a/python/python3-pickleshare/python3-pickleshare.SlackBuild b/python/python3-pickleshare/python3-pickleshare.SlackBuild
new file mode 100644
index 0000000000..27d7c4fcb3
--- /dev/null
+++ b/python/python3-pickleshare/python3-pickleshare.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for python3-pickleshare
+
+# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+SRCNAM=pickleshare
+PRGNAM=python3-$SRCNAM
+VERSION=${VERSION:-0.7.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-pickleshare/python3-pickleshare.info b/python/python3-pickleshare/python3-pickleshare.info
new file mode 100644
index 0000000000..8965ad2d02
--- /dev/null
+++ b/python/python3-pickleshare/python3-pickleshare.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-pickleshare"
+VERSION="0.7.4"
+HOMEPAGE="https://jupyter.org/"
+DOWNLOAD="https://github.com/pickleshare/pickleshare/archive/0.7.4/pickleshare-0.7.4.tar.gz"
+MD5SUM="edd1fc04bc12d9748c852218d2cb86fd"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"
diff --git a/python/python3-pickleshare/slack-desc b/python/python3-pickleshare/slack-desc
new file mode 100644
index 0000000000..ff0d60fe7a
--- /dev/null
+++ b/python/python3-pickleshare/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-pickleshare: python3-pickleshare (file system based database for Python 3)
+python3-pickleshare:
+python3-pickleshare: PickleShare is a small shelve-like datastore with concurrency
+python3-pickleshare: support.
+python3-pickleshare:
+python3-pickleshare: Like shelve, a PickleShareDB object acts like a normal dictionary.
+python3-pickleshare: Unlike shelve, many processes can access the database simultaneously.
+python3-pickleshare: Changing a value in database is immediately visible to other
+python3-pickleshare: processes accessing the same database.
+python3-pickleshare:
+python3-pickleshare: