summaryrefslogtreecommitdiffstats
path: root/python/python3-pep517
diff options
context:
space:
mode:
author fourtysixandtwo2023-05-27 16:27:40 +0200
committer Willy Sudiarto Raharjo2023-06-10 04:23:03 +0200
commitc10d2c13c1354c91d60758b30290ac7b39890567 (patch)
tree70bd7fbb38a57dfec789e882e9f3509b3779a23e /python/python3-pep517
parentbd3db238c3b5cdd5bf0d104417138dafd8321b5f (diff)
downloadslackbuilds-c10d2c13c1354c91d60758b30290ac7b39890567.tar.gz
python/python3-pep517: Removed: (replaced by python3-pyproject-hooks)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-pep517')
-rw-r--r--python/python3-pep517/README12
-rw-r--r--python/python3-pep517/python3-pep517.SlackBuild98
-rw-r--r--python/python3-pep517/python3-pep517.info10
-rw-r--r--python/python3-pep517/slack-desc19
4 files changed, 0 insertions, 139 deletions
diff --git a/python/python3-pep517/README b/python/python3-pep517/README
deleted file mode 100644
index 9afe18548c..0000000000
--- a/python/python3-pep517/README
+++ /dev/null
@@ -1,12 +0,0 @@
-PEP 517 specifies a standard API for systems which build Python
-packages.
-
-PEP 660 extends it with a build mode that leads to editable installs.
-
-This package contains wrappers around the hooks specified by PEP 517
-and PEP 660. It provides:
-
-- A mechanism to call the hooks in a subprocess, so they are isolated
- from the current process.
-- Fallbacks for the optional hooks, so that frontends can call the
- hooks without checking which are defined.
diff --git a/python/python3-pep517/python3-pep517.SlackBuild b/python/python3-pep517/python3-pep517.SlackBuild
deleted file mode 100644
index d959f41d3d..0000000000
--- a/python/python3-pep517/python3-pep517.SlackBuild
+++ /dev/null
@@ -1,98 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for python3-pep517
-
-# Copyright 2022 toolonely <lonely_@tutanota.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=python3-pep517
-VERSION=${VERSION:-0.12.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-SRCNAM=pep517
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- PKG-INFO \
- README.rst \
- LICENSE \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-pep517/python3-pep517.info b/python/python3-pep517/python3-pep517.info
deleted file mode 100644
index f83db92a03..0000000000
--- a/python/python3-pep517/python3-pep517.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python3-pep517"
-VERSION="0.12.0"
-HOMEPAGE="https://github.com/pypa/pep517"
-DOWNLOAD="https://files.pythonhosted.org/packages/0a/65/6e656d49c679136edfba25f25791f45ffe1ea4ae2ec1c59fe9c35e061cd1/pep517-0.12.0.tar.gz"
-MD5SUM="7ed0adb5f737c316e071d48d66329a5d"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="toolonely"
-EMAIL="lonely_@tutanota.com"
diff --git a/python/python3-pep517/slack-desc b/python/python3-pep517/slack-desc
deleted file mode 100644
index ff3f131524..0000000000
--- a/python/python3-pep517/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python3-pep517: python3-pep517 (API to call PEP 517 hooks)
-python3-pep517:
-python3-pep517: This package contains wrappers around the hooks specified by PEP 517
-python3-pep517: and PEP 660. It provides:
-python3-pep517:
-python3-pep517: - A mechanism to call the hooks in a subprocess, so they are isolated
-python3-pep517: from the current process.
-python3-pep517: - Fallbacks for the optional hooks, so that frontends can call
-python3-pep517: the hooks without checking which are defined.
-python3-pep517:
-python3-pep517: