summaryrefslogtreecommitdiffstats
path: root/python/python3-paste
diff options
context:
space:
mode:
author Arn02022-03-08 23:52:01 +0100
committer Willy Sudiarto Raharjo2022-03-09 06:37:58 +0100
commitde0d81ff8c737e30907d155851d4b45aea39438c (patch)
tree245785c5205d05dac91ca913939dcac19190410d /python/python3-paste
parentd3cc19e445e3eb6ccd9dd7a40ab59cabaee12d47 (diff)
downloadslackbuilds-de0d81ff8c737e30907d155851d4b45aea39438c.tar.gz
python/python3-paste: renamed from Paste for python3
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-paste')
-rw-r--r--python/python3-paste/README9
-rw-r--r--python/python3-paste/python3-paste.SlackBuild77
-rw-r--r--python/python3-paste/python3-paste.info10
-rw-r--r--python/python3-paste/slack-desc19
4 files changed, 115 insertions, 0 deletions
diff --git a/python/python3-paste/README b/python/python3-paste/README
new file mode 100644
index 0000000000..895b98c38a
--- /dev/null
+++ b/python/python3-paste/README
@@ -0,0 +1,9 @@
+Paste provides several pieces of "middleware" (or filters) that can be nested to
+build web applications.
+Each piece of middleware uses the WSGI (PEP 333) interface, and should be
+compatible with other middleware based on those interfaces.
+
+
+Paste is in maintenance mode and recently moved from bitbucket to github.
+Patches are accepted to keep it on life support, but for the most part,
+please consider using other options.
diff --git a/python/python3-paste/python3-paste.SlackBuild b/python/python3-paste/python3-paste.SlackBuild
new file mode 100644
index 0000000000..57e753fb4e
--- /dev/null
+++ b/python/python3-paste/python3-paste.SlackBuild
@@ -0,0 +1,77 @@
+#!/bin/bash
+
+# SlackBuild script for Paste.
+# Yth | Pont-en-Royans, France | yth@ythogtha.org
+
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-paste
+SRCNAM=Paste
+VERSION=${VERSION:-3.5.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst MANIFEST.in $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-paste/python3-paste.info b/python/python3-paste/python3-paste.info
new file mode 100644
index 0000000000..1f6da34b12
--- /dev/null
+++ b/python/python3-paste/python3-paste.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-paste"
+VERSION="3.5.0"
+HOMEPAGE="https://pythonpaste.readthedocs.io/"
+DOWNLOAD="https://pypi.python.org/packages/source/P/Paste/Paste-3.5.0.tar.gz"
+MD5SUM="90c56e0f84c58ca4841c0df0bcfc11d9"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/python3-paste/slack-desc b/python/python3-paste/slack-desc
new file mode 100644
index 0000000000..ff8ceb97ea
--- /dev/null
+++ b/python/python3-paste/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-paste: python3-paste (Middleware)
+python3-paste:
+python3-paste: Paste provides several pieces of "middleware" (or filters) that can
+python3-paste: be nested to build web applications.
+python3-paste:
+python3-paste: Each piece of middleware uses the WSGI (PEP 333) interface, and
+python3-paste: should be compatible with other middleware based on those interfaces.
+python3-paste:
+python3-paste:
+python3-paste:
+python3-paste: