summaryrefslogtreecommitdiffstats
path: root/python/python3-mpmath
diff options
context:
space:
mode:
author Alexander Verbovetsky2019-07-27 02:33:53 +0200
committer Willy Sudiarto Raharjo2019-07-27 02:33:53 +0200
commit3f7577db577a93738e7b8fe55f7d7a8bd4e0e5e7 (patch)
treec9fa2b86ba79fd50f2387f74b34fb28968efe5c8 /python/python3-mpmath
parent46fffcd2c808aa86ebc6f81f8184b2b3d3cc44ba (diff)
downloadslackbuilds-3f7577db577a93738e7b8fe55f7d7a8bd4e0e5e7.tar.gz
python/python3-mpmath: Added (arithmetic library).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-mpmath')
-rw-r--r--python/python3-mpmath/README6
-rw-r--r--python/python3-mpmath/python3-mpmath.SlackBuild91
-rw-r--r--python/python3-mpmath/python3-mpmath.info10
-rw-r--r--python/python3-mpmath/slack-desc19
4 files changed, 126 insertions, 0 deletions
diff --git a/python/python3-mpmath/README b/python/python3-mpmath/README
new file mode 100644
index 0000000000..a74dd4742b
--- /dev/null
+++ b/python/python3-mpmath/README
@@ -0,0 +1,6 @@
+mpmath is a free (BSD licensed) Python library for real and complex
+floating-point arithmetic with arbitrary precision. It has been developed
+by Fredrik Johansson since 2007, with help from many contributors.
+
+This is the python3 version of mpmath and it can coexist with SBo's
+mpmath package.
diff --git a/python/python3-mpmath/python3-mpmath.SlackBuild b/python/python3-mpmath/python3-mpmath.SlackBuild
new file mode 100644
index 0000000000..4753945f4d
--- /dev/null
+++ b/python/python3-mpmath/python3-mpmath.SlackBuild
@@ -0,0 +1,91 @@
+#!/bin/sh
+
+# Slackware build script for python3-mpmath
+
+# Copyright SlackBuilds.org Project, David Melik, 2015, Spokane, WA, USA
+# Copyright 2019, Alexander Verbovetsky, Moscow, Russia
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python3-mpmath
+SRCNAM=mpmath
+VERSION=${VERSION:-1.1.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+find ./ -type f -name '*.py' -exec \
+ sed -i -e 's|#!/usr/bin/python\>|#!/usr/bin/python3|' \
+ -e 's|#!/usr/bin/env python\>|#!/usr/bin/env python3|' {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES LICENSE README.rst TODO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-mpmath/python3-mpmath.info b/python/python3-mpmath/python3-mpmath.info
new file mode 100644
index 0000000000..47a300912c
--- /dev/null
+++ b/python/python3-mpmath/python3-mpmath.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-mpmath"
+VERSION="1.1.0"
+HOMEPAGE="http://mpmath.org/"
+DOWNLOAD="https://github.com/fredrik-johansson/mpmath/archive/1.1.0/mpmath-1.1.0.tar.gz"
+MD5SUM="c06bdf456bbbf092c929931974c8dac9"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Alexander Verbovetsky"
+EMAIL="alik@ejik.org"
diff --git a/python/python3-mpmath/slack-desc b/python/python3-mpmath/slack-desc
new file mode 100644
index 0000000000..95948c260a
--- /dev/null
+++ b/python/python3-mpmath/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-mpmath: python3-mpmath (arithmetic library)
+python3-mpmath:
+python3-mpmath: Mpmath is a free (BSD licensed) Python library for real and complex
+python3-mpmath: floating-point arithmetic with arbitrary precision. It has been
+python3-mpmath: developed by Fredrik Johansson since 2007, with help from many
+python3-mpmath: contributors.
+python3-mpmath:
+python3-mpmath: http://mpmath.org/
+python3-mpmath:
+python3-mpmath:
+python3-mpmath: