summaryrefslogtreecommitdiffstats
path: root/python/python3-ipython
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2018-04-03 06:53:37 +0200
committer Benjamin Trigona-Harany2018-04-03 06:53:37 +0200
commit945f4005f919e357d244f6e76747c9bae40ca0ef (patch)
treef6cac253de7d842916b67e028b90ab69f267e0d4 /python/python3-ipython
parent8d8abe05732e7e6178c245b4709a80a9d687f377 (diff)
downloadslackbuilds-945f4005f919e357d244f6e76747c9bae40ca0ef.tar.gz
python/python3-ipython: Updated for version 6.3.0.
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
Diffstat (limited to 'python/python3-ipython')
-rw-r--r--python/python3-ipython/python3-ipython.SlackBuild28
-rw-r--r--python/python3-ipython/python3-ipython.info8
2 files changed, 19 insertions, 17 deletions
diff --git a/python/python3-ipython/python3-ipython.SlackBuild b/python/python3-ipython/python3-ipython.SlackBuild
index 6195db5559..1d489fb641 100644
--- a/python/python3-ipython/python3-ipython.SlackBuild
+++ b/python/python3-ipython/python3-ipython.SlackBuild
@@ -1,9 +1,8 @@
#!/bin/sh
-# SlackBuild for IPython
+# SlackBuild for python3-ipython
-# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# Copyright 2008-2011 Carlos Corbacho <carlos@strangeworlds.co.uk>
+# Copyright 2017-2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +24,7 @@
SRCNAM=ipython
PRGNAM=python3-$SRCNAM
-VERSION=${VERSION:-6.2.1}
+VERSION=${VERSION:-6.3.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -41,7 +40,6 @@ CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-DOCS=${DOCS:-no}
set -e
@@ -51,17 +49,20 @@ cd $TMP
rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
-
+chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root="$PKG"
+python3 setup.py install --root=$PKG
rm $PKG/usr/bin/iptest
rm $PKG/usr/bin/ipython
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
mkdir -p $PKG/usr/man/man1
mv $PKG/usr/share/man/man1/$SRCNAM.1 $PKG/usr/man/man1/${SRCNAM}3.1
find $PKG/usr/man -type f -exec gzip -9 {} \;
@@ -71,8 +72,9 @@ for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; r
rm -rf $PKG/usr/share
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-
-cp COPYING.rst README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp \
+ COPYING.rst README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/python3-ipython/python3-ipython.info b/python/python3-ipython/python3-ipython.info
index 79458e802c..2d108c6bea 100644
--- a/python/python3-ipython/python3-ipython.info
+++ b/python/python3-ipython/python3-ipython.info
@@ -1,10 +1,10 @@
PRGNAM="python3-ipython"
-VERSION="6.2.1"
+VERSION="6.3.0"
HOMEPAGE="http://ipython.org"
-DOWNLOAD="https://github.com/ipython/ipython/archive/6.2.1/ipython-6.2.1.tar.gz"
-MD5SUM="fe8704b6b28c05cf608e0747a7c983ec"
+DOWNLOAD="https://github.com/ipython/ipython/archive/6.3.0/ipython-6.3.0.tar.gz"
+MD5SUM="944ead51f09e4e1287974f7cd36a9748"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3-decorator python3-ipython_genutils python3-jedi python3-pexpect python3-pickleshare python3-prompt_toolkit python3-Pygments python3-simplegeneric python3-traitlets"
+REQUIRES="python3-decorator python3-ipython_genutils python3-jedi python3-pexpect python3-pickleshare python3-prompt_toolkit python3-Pygments python3-simplegeneric python3-traitlets backcall"
MAINTAINER="Benjamin Trigona-Harany"
EMAIL="slackbuilds@jaxartes.net"