summaryrefslogtreecommitdiffstats
path: root/python/python3-aiorpcX
diff options
context:
space:
mode:
author Isaac Yu2019-03-13 17:25:33 +0100
committer Willy Sudiarto Raharjo2019-03-16 00:53:25 +0100
commitd117632796e9bfbdd1cd6fb5b761e37afae3391c (patch)
treee119600d3e6d19b03853a24e580b2e9170fde749 /python/python3-aiorpcX
parentd08ca56e4b2ea8c9576c0368489dcb74157c9613 (diff)
downloadslackbuilds-d117632796e9bfbdd1cd6fb5b761e37afae3391c.tar.gz
python/python3-aiorpcX: Added (Generic async RPC implementation).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-aiorpcX')
-rw-r--r--python/python3-aiorpcX/README2
-rw-r--r--python/python3-aiorpcX/python3-aiorpcX.SlackBuild85
-rw-r--r--python/python3-aiorpcX/python3-aiorpcX.info10
-rw-r--r--python/python3-aiorpcX/slack-desc19
4 files changed, 116 insertions, 0 deletions
diff --git a/python/python3-aiorpcX/README b/python/python3-aiorpcX/README
new file mode 100644
index 0000000000..d522fcf2a2
--- /dev/null
+++ b/python/python3-aiorpcX/README
@@ -0,0 +1,2 @@
+aiorpcX is a generic asyncio library implementation of RPC suitable
+for an application that is a client, server or both.
diff --git a/python/python3-aiorpcX/python3-aiorpcX.SlackBuild b/python/python3-aiorpcX/python3-aiorpcX.SlackBuild
new file mode 100644
index 0000000000..4cf8eb4a06
--- /dev/null
+++ b/python/python3-aiorpcX/python3-aiorpcX.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for python3-aiorpcX
+# Copyright 2019 Isaac Yu <isaacyu1@isaacyu1.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python3-aiorpcX
+SRCNAM=aiorpcX
+VERSION=${VERSION:-0.10.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst docs/ LICENCE $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-aiorpcX/python3-aiorpcX.info b/python/python3-aiorpcX/python3-aiorpcX.info
new file mode 100644
index 0000000000..4278931681
--- /dev/null
+++ b/python/python3-aiorpcX/python3-aiorpcX.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-aiorpcX"
+VERSION="0.10.5"
+HOMEPAGE="https://aiorpcx.readthedocs.io/en/stable/"
+DOWNLOAD="https://github.com/kyuupichan/aiorpcX/archive/0.10.5/aiorpcX-0.10.5.tar.gz"
+MD5SUM="3b3e9abcffe3c47d046143a2d2306083"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-attrs"
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu1@isaacyu1.com"
diff --git a/python/python3-aiorpcX/slack-desc b/python/python3-aiorpcX/slack-desc
new file mode 100644
index 0000000000..dd49874776
--- /dev/null
+++ b/python/python3-aiorpcX/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-aiorpcX: python3-aiorpcX (Generic async RPC implementation)
+python3-aiorpcX:
+python3-aiorpcX: aiorpcX is a generic asyncio library implementation of RPC suitable
+python3-aiorpcX: for an application that is a client, server or both.
+python3-aiorpcX:
+python3-aiorpcX: https://aiorpcx.readthedocs.io/en/stable/
+python3-aiorpcX:
+python3-aiorpcX:
+python3-aiorpcX:
+python3-aiorpcX:
+python3-aiorpcX: