summaryrefslogtreecommitdiffstats
path: root/python/python2-transaction
diff options
context:
space:
mode:
author Dave Woodfall2021-05-06 18:11:26 +0200
committer Willy Sudiarto Raharjo2021-05-07 20:41:51 +0200
commitd50f427d4ecc9bf6b57e162bc85bdaf16df3652a (patch)
treedde2d2ec680d8df8922f45f8dce809b5f3239291 /python/python2-transaction
parent393b89f89f8cc63bb66cc4f236256d01495ecd9f (diff)
downloadslackbuilds-d50f427d4ecc9bf6b57e162bc85bdaf16df3652a.tar.gz
python/python-transaction: Renamed python2-transaction.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python2-transaction')
-rw-r--r--python/python2-transaction/README8
-rw-r--r--python/python2-transaction/python2-transaction.SlackBuild73
-rw-r--r--python/python2-transaction/python2-transaction.info10
-rw-r--r--python/python2-transaction/slack-desc19
4 files changed, 110 insertions, 0 deletions
diff --git a/python/python2-transaction/README b/python/python2-transaction/README
new file mode 100644
index 0000000000..8c1d022bd7
--- /dev/null
+++ b/python/python2-transaction/README
@@ -0,0 +1,8 @@
+This package contains a generic transaction implementation for Python.
+It is mainly used by the ZODB, though.
+
+Note that the data manager API, transaction.interfaces.IDataManager, is
+syntactically simple, but semantically complex. The semantics were not
+easy to express in the interface. This could probably use more work. The
+semantics are presented in detail through examples of a sample data
+manager in transaction.tests.test_SampleDataManager.
diff --git a/python/python2-transaction/python2-transaction.SlackBuild b/python/python2-transaction/python2-transaction.SlackBuild
new file mode 100644
index 0000000000..b14885edc3
--- /dev/null
+++ b/python/python2-transaction/python2-transaction.SlackBuild
@@ -0,0 +1,73 @@
+#!/bin/sh
+# Generated by Alien's SlackBuild Toolkit: http://slackware.com/~alien/AST
+# Copyright 2009 Eric Hameleers <alien@slackware.com>, Eindhoven, Netherlands
+
+# Slackware build script for python-transaction
+
+# Written by Lionel Young <redtricycle@gmail.com>
+
+PRGNAM=python2-transaction
+SRCNAM=transaction
+VERSION=${VERSION:-1.0.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python2 setup.py build || exit 1
+python2 setup.py install --root=$PKG || exit 1
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGES.txt LICENSE.txt README.txt COPYRIGHT.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python2-transaction/python2-transaction.info b/python/python2-transaction/python2-transaction.info
new file mode 100644
index 0000000000..072626bc1b
--- /dev/null
+++ b/python/python2-transaction/python2-transaction.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-transaction"
+VERSION="1.0.0"
+HOMEPAGE="https://pypi.python.org/pypi/transaction"
+DOWNLOAD="https://pypi.python.org/packages/source/t/transaction/transaction-1.0.0.tar.gz"
+MD5SUM="10b5d02dcded26f6f265771e6d68fc06"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Lionel Young"
+EMAIL="redtricycle@gmail.com"
diff --git a/python/python2-transaction/slack-desc b/python/python2-transaction/slack-desc
new file mode 100644
index 0000000000..f3b0c1c060
--- /dev/null
+++ b/python/python2-transaction/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-transaction: python2-transaction (Python Transaction Management)
+python2-transaction:
+python2-transaction: This is a generic transaction implementation for Python. It
+python2-transaction: is mainly used by the ZODB. Note that the data manager API,
+python2-transaction: transaction.interfaces.IDataManager, is syntactically simple, but
+python2-transaction: semantically complex. The semantics were not easy to express in the
+python2-transaction: interface. The semantics are presented in detail through examples
+python2-transaction: of a sample data manager in transaction.tests.test_SampleDataManager.
+python2-transaction:
+python2-transaction:
+python2-transaction: Homepage: https://pypi.python.org/pypi/transaction