summaryrefslogtreecommitdiffstats
path: root/python/python2-soupsieve
diff options
context:
space:
mode:
author B. Watson2022-04-15 19:50:55 +0200
committer Willy Sudiarto Raharjo2022-04-16 07:11:30 +0200
commitc6d0e105e462a0b99029d27b2dcc7ddd5e250661 (patch)
tree37a81c4c7449aca9b539956787e2ede304c986a2 /python/python2-soupsieve
parent62c08f78232883311e8198740526260de843a380 (diff)
downloadslackbuilds-c6d0e105e462a0b99029d27b2dcc7ddd5e250661.tar.gz
python/python2-soupsieve: Fix docs.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python2-soupsieve')
-rw-r--r--python/python2-soupsieve/python2-soupsieve.SlackBuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/python/python2-soupsieve/python2-soupsieve.SlackBuild b/python/python2-soupsieve/python2-soupsieve.SlackBuild
index 4bdb9c7266..dd3065707e 100644
--- a/python/python2-soupsieve/python2-soupsieve.SlackBuild
+++ b/python/python2-soupsieve/python2-soupsieve.SlackBuild
@@ -22,11 +22,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220415 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - clean up the doc dir.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python2-soupsieve
VERSION=${VERSION:-1.9.6}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -40,9 +43,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -77,17 +77,20 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# 20220415 bkw: since we can't build the HTML docs from the markdown
+# source (we lack the tools), just put the markdown files in the doc dir.
+# they're pretty readable as-is.
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.md docs/ requirements/ $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $( find . -type f -name \*.md ) $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install