summaryrefslogtreecommitdiffstats
path: root/python/python2-simpy
diff options
context:
space:
mode:
author Dave Woodfall2021-05-03 07:50:18 +0200
committer Robby Workman2021-05-03 08:49:58 +0200
commiteedbb272487e9d6bf7f8c020580f809a1c92a751 (patch)
tree505757030dda60a8d35c52ceb680be1f3e34e299 /python/python2-simpy
parent7e8912f3591c6ec8e0c8dec299a997cb2064e951 (diff)
downloadslackbuilds-eedbb272487e9d6bf7f8c020580f809a1c92a751.tar.gz
python/python-simpy: Renamed python2-simpy.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org>
Diffstat (limited to 'python/python2-simpy')
-rw-r--r--python/python2-simpy/README18
-rw-r--r--python/python2-simpy/python2-simpy.SlackBuild73
-rw-r--r--python/python2-simpy/python2-simpy.info10
-rw-r--r--python/python2-simpy/slack-desc19
4 files changed, 120 insertions, 0 deletions
diff --git a/python/python2-simpy/README b/python/python2-simpy/README
new file mode 100644
index 0000000000..e5ce2fe430
--- /dev/null
+++ b/python/python2-simpy/README
@@ -0,0 +1,18 @@
+SimPy
+=====
+
+SimPy is a process-based discrete-event simulation language based on
+standard Python and released under the GNU LGPL.
+
+It provides the modeller with components of a simulation model. These
+include processes for active components like customers, messages and
+vehicles as well as resources for passive components that form limited
+capacity congestion points (like servers, checkout counters and
+tunnels). It also provides monitor variables to aid in gathering
+statistics. SimPy comes with extensive plotting capabilities.
+
+The distribution contains in-depth documentation, tutorials, and a large
+number of simulation models.
+
+To build documentation, pass DOCS=yes to the slackbuild. Requires the
+optional dependency Sphinx.
diff --git a/python/python2-simpy/python2-simpy.SlackBuild b/python/python2-simpy/python2-simpy.SlackBuild
new file mode 100644
index 0000000000..987afd3600
--- /dev/null
+++ b/python/python2-simpy/python2-simpy.SlackBuild
@@ -0,0 +1,73 @@
+#!/bin/sh
+
+# Slackware build script for SimPy
+
+# Written by John Tyree <johntyree+sbo@gmail.com>
+
+PRGNAM=python2-simpy
+VERSION=${VERSION:-3.0.10}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+SRCNAM=simpy
+DOCS=${DOCS:-"no"}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python2 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+if [[ $DOCS == "yes" ]]; then
+ (cd ./docs; make html; cp -a html $PKG/usr/doc/$PRGNAM-$VERSION)
+fi
+cp -a AUTHORS.txt CHANGES.txt LICENSE.txt README.txt docs/examples \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python2-simpy/python2-simpy.info b/python/python2-simpy/python2-simpy.info
new file mode 100644
index 0000000000..e554717a84
--- /dev/null
+++ b/python/python2-simpy/python2-simpy.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-simpy"
+VERSION="3.0.10"
+HOMEPAGE="https://pypi.python.org/pypi/simpy"
+DOWNLOAD="https://pypi.python.org/packages/81/87/074e97b833d35e2979e6a67fe2fdc26c0178bf1ce5a3a6ea999e771688dd/simpy-3.0.10.tar.gz"
+MD5SUM="a968f5562d6f2292a139f8a445e2f7d5"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="John Tyree"
+EMAIL="johntyree+sbo@gmail.com"
diff --git a/python/python2-simpy/slack-desc b/python/python2-simpy/slack-desc
new file mode 100644
index 0000000000..646abb372e
--- /dev/null
+++ b/python/python2-simpy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-simpy: python2-simpy (Object Oriented Discrete Event Simulation in Python)
+python2-simpy:
+python2-simpy: SimPy (= Simulation in Python) is an object-oriented, process-based
+python2-simpy: discrete-event simulation language based on standard Python. It
+python2-simpy: provides the modeller with components of a simulation model including
+python2-simpy: processes, for active components like customers, messages, and
+python2-simpy: vehicles, and resources, for passive components that form limited
+python2-simpy: capacity congestion points like servers, checkout counters, and
+python2-simpy: tunnels.
+python2-simpy:
+python2-simpy: https://pypi.python.org/pypi/simpy