summaryrefslogtreecommitdiffstats
path: root/python/python2-pyicu
diff options
context:
space:
mode:
author Heinz Wiesinger2022-01-23 11:22:09 +0100
committer Willy Sudiarto Raharjo2022-01-25 08:44:38 +0100
commit49a04b746c10a20e2b45d6ed763bb53af5f5f6de (patch)
tree368c216c1e11afe2ae92cb5d67e49d347f211754 /python/python2-pyicu
parenta706820fa0860bb7e46f2dc1f33d666f214d8d39 (diff)
downloadslackbuilds-49a04b746c10a20e2b45d6ed763bb53af5f5f6de.tar.gz
python/python2-pyicu: Renamed from pyicu and updated for version 2.8
Signed-off-by: Heinz Wiesinger <pprkut@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python2-pyicu')
-rw-r--r--python/python2-pyicu/README2
-rw-r--r--python/python2-pyicu/python2-pyicu.SlackBuild84
-rw-r--r--python/python2-pyicu/python2-pyicu.info10
-rw-r--r--python/python2-pyicu/slack-desc19
4 files changed, 115 insertions, 0 deletions
diff --git a/python/python2-pyicu/README b/python/python2-pyicu/README
new file mode 100644
index 0000000000..86100eea25
--- /dev/null
+++ b/python/python2-pyicu/README
@@ -0,0 +1,2 @@
+PyICU is a Python extension wrapping IBM's International
+Components for Unicode C++ library (ICU).
diff --git a/python/python2-pyicu/python2-pyicu.SlackBuild b/python/python2-pyicu/python2-pyicu.SlackBuild
new file mode 100644
index 0000000000..9dbb181ae2
--- /dev/null
+++ b/python/python2-pyicu/python2-pyicu.SlackBuild
@@ -0,0 +1,84 @@
+#!/bin/bash
+
+# Slackware build script for python2-pyicu
+
+# Copyright 2009-2022 Heinz Wiesinger, Amsterdam, The Netherlands
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python2-pyicu
+VERSION=${VERSION:-2.8}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+SRCNAM=PyICU
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python2 setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES PKG-INFO README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python2-pyicu/python2-pyicu.info b/python/python2-pyicu/python2-pyicu.info
new file mode 100644
index 0000000000..2da4c7cc0e
--- /dev/null
+++ b/python/python2-pyicu/python2-pyicu.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-pyicu"
+VERSION="2.8"
+HOMEPAGE="https://github.com/ovalhub/pyicu"
+DOWNLOAD="https://files.pythonhosted.org/packages/1a/b6/ede5f19d79655898162afa778d2f38cbde04b0cccb8737c649cd5d3d38e0/PyICU-2.8.tar.gz"
+MD5SUM="307fe365cf75fec1d1f744c387ac67d8"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Heinz Wiesinger"
+EMAIL="pprkut@slackbuilds.org"
diff --git a/python/python2-pyicu/slack-desc b/python/python2-pyicu/slack-desc
new file mode 100644
index 0000000000..d70f51cc65
--- /dev/null
+++ b/python/python2-pyicu/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-pyicu: python2-pyicu (python wrapper for icu4c)
+python2-pyicu:
+python2-pyicu: PyICU is a Python extension wrapping IBM's International
+python2-pyicu: Components for Unicode C++ library (ICU).
+python2-pyicu:
+python2-pyicu: Homepage: https://github.com/ovalhub/pyicu
+python2-pyicu:
+python2-pyicu:
+python2-pyicu:
+python2-pyicu:
+python2-pyicu: