summaryrefslogtreecommitdiffstats
path: root/python/python2-pycrypto
diff options
context:
space:
mode:
author Heinz Wiesinger2021-10-10 16:46:44 +0200
committer Willy Sudiarto Raharjo2021-10-12 19:51:23 +0200
commit44a2862f70e02dbf3842255e54c569ee8e800402 (patch)
treed6f6e70ba13a896123804c84e627db3408c5e7f4 /python/python2-pycrypto
parent7414c5c325f2b4c1a0028d5a7e9ae7ec5785d707 (diff)
downloadslackbuilds-44a2862f70e02dbf3842255e54c569ee8e800402.tar.gz
python/python2-pycrypto: Renamed to clarify it's python2 only
Signed-off-by: Heinz Wiesinger <pprkut@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python2-pycrypto')
-rw-r--r--python/python2-pycrypto/README3
-rw-r--r--python/python2-pycrypto/python2-pycrypto.SlackBuild83
-rw-r--r--python/python2-pycrypto/python2-pycrypto.info10
-rw-r--r--python/python2-pycrypto/slack-desc19
4 files changed, 115 insertions, 0 deletions
diff --git a/python/python2-pycrypto/README b/python/python2-pycrypto/README
new file mode 100644
index 0000000000..ed20575779
--- /dev/null
+++ b/python/python2-pycrypto/README
@@ -0,0 +1,3 @@
+This is a collection of both secure hash functions (such as MD5 and SHA),
+and various encryption algorithms (AES, DES, IDEA, RSA, ElGamal, etc.).
+The package is structured to make adding new modules easy.
diff --git a/python/python2-pycrypto/python2-pycrypto.SlackBuild b/python/python2-pycrypto/python2-pycrypto.SlackBuild
new file mode 100644
index 0000000000..bb9bc9099c
--- /dev/null
+++ b/python/python2-pycrypto/python2-pycrypto.SlackBuild
@@ -0,0 +1,83 @@
+#!/bin/bash
+
+# Slackware build script for pycrypto
+
+# Copyright 2008-2021 Heinz Wiesinger, Amsterdam, The Netherlands
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+SRCNAM=pycrypto
+PRGNAM=python2-$SRCNAM
+VERSION=${VERSION:-2.6.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python2 setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a ACKS ChangeLog COPYRIGHT README TODO Doc \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python2-pycrypto/python2-pycrypto.info b/python/python2-pycrypto/python2-pycrypto.info
new file mode 100644
index 0000000000..d5c34050d4
--- /dev/null
+++ b/python/python2-pycrypto/python2-pycrypto.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-pycrypto"
+VERSION="2.6.1"
+HOMEPAGE="https://www.dlitz.net/software/pycrypto/"
+DOWNLOAD="https://pypi.python.org/packages/source/p/pycrypto/pycrypto-2.6.1.tar.gz"
+MD5SUM="55a61a054aa66812daf5161a0d5d7eda"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Heinz Wiesinger"
+EMAIL="pprkut@slackbuilds.org"
diff --git a/python/python2-pycrypto/slack-desc b/python/python2-pycrypto/slack-desc
new file mode 100644
index 0000000000..80616e6b0c
--- /dev/null
+++ b/python/python2-pycrypto/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-pycrypto: python2-pycrypto (Python Cryptography Toolkit)
+python2-pycrypto:
+python2-pycrypto: This is a collection of both secure hash functions (such as MD5 and
+python2-pycrypto: SHA), and various encryption algorithms (AES, DES, IDEA, RSA,
+python2-pycrypto: ElGamal, etc.). The package is structured to make adding new
+python2-pycrypto: modules easy.
+python2-pycrypto:
+python2-pycrypto: Homepage: http://www.pycrypto.org
+python2-pycrypto:
+python2-pycrypto:
+python2-pycrypto: