summaryrefslogtreecommitdiffstats
path: root/python/python2-pbr
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2021-11-25 03:20:36 +0100
committer Willy Sudiarto Raharjo2021-11-25 03:20:36 +0100
commit93a74069f675d47a4b8e9bb91f35a3c149f5cad1 (patch)
treeb86e0a156a3c53bbc5cf51bec34eac89a266069b /python/python2-pbr
parente9be7a871ad0baa6a25443975be1b39560e66e92 (diff)
downloadslackbuilds-93a74069f675d47a4b8e9bb91f35a3c149f5cad1.tar.gz
python-python2-pbr: Renamed from pbr.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python2-pbr')
-rw-r--r--python/python2-pbr/README10
-rw-r--r--python/python2-pbr/python2-pbr.SlackBuild98
-rw-r--r--python/python2-pbr/python2-pbr.info10
-rw-r--r--python/python2-pbr/slack-desc19
4 files changed, 137 insertions, 0 deletions
diff --git a/python/python2-pbr/README b/python/python2-pbr/README
new file mode 100644
index 0000000000..e2eab1ceae
--- /dev/null
+++ b/python/python2-pbr/README
@@ -0,0 +1,10 @@
+PBR is a library that injects some useful and sensible default
+behaviors into your setuptools run.
+
+PBR is only mildly configurable. The basic idea is that there's a
+decent way to run things and if you do, you should reap the rewards,
+because then it's simple and repeatable. If you want to do things
+differently, cool! But you've already got the power of python at your
+fingertips, so you don't really need PBR.
+
+NOTE: This package consist of python2 module only.
diff --git a/python/python2-pbr/python2-pbr.SlackBuild b/python/python2-pbr/python2-pbr.SlackBuild
new file mode 100644
index 0000000000..e4ceefc4f4
--- /dev/null
+++ b/python/python2-pbr/python2-pbr.SlackBuild
@@ -0,0 +1,98 @@
+#!/bin/bash
+
+# Slackware build script for python2-pbr
+
+# Copyright 2014 Bogdan Radulescu, Bucharest, Romania
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python2-pbr
+SRCNAM=pbr
+VERSION=${VERSION:-5.6.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i686 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python2 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
+ grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS ChangeLog PKG-INFO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python2-pbr/python2-pbr.info b/python/python2-pbr/python2-pbr.info
new file mode 100644
index 0000000000..07695dad77
--- /dev/null
+++ b/python/python2-pbr/python2-pbr.info
@@ -0,0 +1,10 @@
+PRGNAM="pbr"
+VERSION="5.6.0"
+HOMEPAGE="https://pypi.python.org/pypi/pbr"
+DOWNLOAD="https://files.pythonhosted.org/packages/35/8c/69ed04ae31ad498c9bdea55766ed4c0c72de596e75ac0d70b58aa25e0acf/pbr-5.6.0.tar.gz"
+MD5SUM="62565acc6bf3e7e10b082463421f8b46"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Bogdan Radulescu"
+EMAIL="bogdan@nimblex.net"
diff --git a/python/python2-pbr/slack-desc b/python/python2-pbr/slack-desc
new file mode 100644
index 0000000000..72f7a6823b
--- /dev/null
+++ b/python/python2-pbr/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-pbr: python2-pbr (managing setuptools packaging in python)
+python2-pbr:
+python2-pbr: A library for managing setuptools packaging in a consistent manner.
+python2-pbr:
+python2-pbr: pbr reads and then filters the setup.cfg data through a setup hook
+python2-pbr: to fill in default values and provide more sensible behaviors,
+python2-pbr: and then feeds the results in as the arguments to a call to setup.py
+python2-pbr:
+python2-pbr:
+python2-pbr:
+python2-pbr: