summaryrefslogtreecommitdiffstats
path: root/python/python2-openid
diff options
context:
space:
mode:
author Dave Woodfall2021-05-03 07:50:16 +0200
committer Robby Workman2021-05-03 08:49:57 +0200
commitc226d01a8d8150d3b441cad73fffd66bf6aba5cf (patch)
tree00683e65fd3f599a7b4e1b75a1e40b5fd61eac39 /python/python2-openid
parent14073927a21038c28368171c102782412fc86a07 (diff)
downloadslackbuilds-c226d01a8d8150d3b441cad73fffd66bf6aba5cf.tar.gz
python/python-openid: Renamed python2-openid.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org>
Diffstat (limited to 'python/python2-openid')
-rw-r--r--python/python2-openid/README1
-rw-r--r--python/python2-openid/python2-openid.SlackBuild71
-rw-r--r--python/python2-openid/python2-openid.info10
-rw-r--r--python/python2-openid/slack-desc19
4 files changed, 101 insertions, 0 deletions
diff --git a/python/python2-openid/README b/python/python2-openid/README
new file mode 100644
index 0000000000..a88bb6bf31
--- /dev/null
+++ b/python/python2-openid/README
@@ -0,0 +1 @@
+Python OpenID library.
diff --git a/python/python2-openid/python2-openid.SlackBuild b/python/python2-openid/python2-openid.SlackBuild
new file mode 100644
index 0000000000..ae4be3ca8b
--- /dev/null
+++ b/python/python2-openid/python2-openid.SlackBuild
@@ -0,0 +1,71 @@
+#!/bin/sh
+# Generated by Alien's SlackBuild Toolkit: http://slackware.com/~alien/AST
+# Copyright 2009 Eric Hameleers <alien@slackware.com>, Eindhoven, Netherlands
+
+# Slackware build script for python-openid
+
+# Written by Lionel Young <redtricycle@gmail.com>
+
+PRGNAM=python2-openid
+SRCNAM=openid-python-openid
+SRCNAMSUF=b666238
+VERSION=${VERSION:-2.2.5}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) export ARCH=i586 ;;
+ arm*) export ARCH=arm ;;
+ *) export ARCH=$( uname -m ) ;;
+ esac
+fi
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION-0-g$SRCNAMSUF.tar.gz
+cd $SRCNAM-$SRCNAMSUF
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python2 setup.py build
+python2 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGES-2.2.0 LICENSE README NOTICE README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python2-openid/python2-openid.info b/python/python2-openid/python2-openid.info
new file mode 100644
index 0000000000..96253edd85
--- /dev/null
+++ b/python/python2-openid/python2-openid.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-openid"
+VERSION="2.2.5"
+HOMEPAGE="https://github.com/openid/python-openid"
+DOWNLOAD="http://ponce.cc/slackware/sources/repo/openid-python-openid-2.2.5-0-gb666238.tar.gz"
+MD5SUM="7bb24dc6abd941ebff6a83c1ac7e4370"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Lionel Young"
+EMAIL="redtricycle@gmail.com"
diff --git a/python/python2-openid/slack-desc b/python/python2-openid/slack-desc
new file mode 100644
index 0000000000..d377c3b053
--- /dev/null
+++ b/python/python2-openid/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-openid: python2-openid (python openid library)
+python2-openid:
+python2-openid: Python OpenID library.
+python2-openid:
+python2-openid: Home: https://github.com/openid/python2-openid
+python2-openid:
+python2-openid:
+python2-openid:
+python2-openid:
+python2-openid:
+python2-openid: