summaryrefslogtreecommitdiffstats
path: root/python/python2-oauth2
diff options
context:
space:
mode:
author Dave Woodfall2021-05-14 22:34:39 +0200
committer Willy Sudiarto Raharjo2021-05-19 13:40:01 +0200
commitfd20879908c701a01e2e0972b37993b7bcf5e181 (patch)
tree5fbafd3ff7cfd50ea1090bab93791f416d55746b /python/python2-oauth2
parentea547454a0afca77834c74a1e460cea1f41b45a3 (diff)
downloadslackbuilds-fd20879908c701a01e2e0972b37993b7bcf5e181.tar.gz
python/python-oauth2: Renamed python2-oauth2.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python2-oauth2')
-rw-r--r--python/python2-oauth2/README2
-rw-r--r--python/python2-oauth2/python2-oauth2.SlackBuild85
-rw-r--r--python/python2-oauth2/python2-oauth2.info10
-rw-r--r--python/python2-oauth2/slack-desc19
4 files changed, 116 insertions, 0 deletions
diff --git a/python/python2-oauth2/README b/python/python2-oauth2/README
new file mode 100644
index 0000000000..08b932276f
--- /dev/null
+++ b/python/python2-oauth2/README
@@ -0,0 +1,2 @@
+A fully tested, abstract interface to creating OAuth clients and
+servers.
diff --git a/python/python2-oauth2/python2-oauth2.SlackBuild b/python/python2-oauth2/python2-oauth2.SlackBuild
new file mode 100644
index 0000000000..d1d6882407
--- /dev/null
+++ b/python/python2-oauth2/python2-oauth2.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for python-oauth2
+# Copyright 2011 David Somero <dsomero@hotmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python2-oauth2
+VERSION=${VERSION:-1.5.211}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM=oauth2
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python2 setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python2-oauth2/python2-oauth2.info b/python/python2-oauth2/python2-oauth2.info
new file mode 100644
index 0000000000..c47d76ef61
--- /dev/null
+++ b/python/python2-oauth2/python2-oauth2.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-oauth2"
+VERSION="1.5.211"
+HOMEPAGE="https://pypi.python.org/pypi/oauth2/"
+DOWNLOAD="https://pypi.python.org/packages/source/o/oauth2/oauth2-1.5.211.tar.gz"
+MD5SUM="987ad7365a70e2286bd1cebb344debbc"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="urlgrabber"
+MAINTAINER="David Somero"
+EMAIL="dsomero@hotmail.com"
diff --git a/python/python2-oauth2/slack-desc b/python/python2-oauth2/slack-desc
new file mode 100644
index 0000000000..5d6e3ac16e
--- /dev/null
+++ b/python/python2-oauth2/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-oauth2: python2-oauth2 (OAuth clients and servers)
+python2-oauth2:
+python2-oauth2: A fully tested, abstract interface to creating OAuth clients and
+python2-oauth2: servers.
+python2-oauth2:
+python2-oauth2:
+python2-oauth2:
+python2-oauth2:
+python2-oauth2:
+python2-oauth2:
+python2-oauth2: