summaryrefslogtreecommitdiffstats
path: root/python/python2-bigfloat
diff options
context:
space:
mode:
author Dave Woodfall2021-05-03 07:48:49 +0200
committer Robby Workman2021-05-03 08:49:56 +0200
commita4d9e3e216437f6c188d073e87d16b758179e9c1 (patch)
treeb7f53321837200027c755cc405b2700bc1607029 /python/python2-bigfloat
parent1b12b817b6a1bcb69cbbb3d1a2e854ae5a4667a0 (diff)
downloadslackbuilds-a4d9e3e216437f6c188d073e87d16b758179e9c1.tar.gz
python/python-bigfloat: Renamed python2-bigfloat.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org>
Diffstat (limited to 'python/python2-bigfloat')
-rw-r--r--python/python2-bigfloat/README17
-rw-r--r--python/python2-bigfloat/doinst.sh3
-rw-r--r--python/python2-bigfloat/python2-bigfloat.SlackBuild71
-rw-r--r--python/python2-bigfloat/python2-bigfloat.info10
-rw-r--r--python/python2-bigfloat/slack-desc19
5 files changed, 120 insertions, 0 deletions
diff --git a/python/python2-bigfloat/README b/python/python2-bigfloat/README
new file mode 100644
index 0000000000..88e23f84b2
--- /dev/null
+++ b/python/python2-bigfloat/README
@@ -0,0 +1,17 @@
+The bigfloat module is a Python wrapper for the MPFR library for
+arbitrary precision floating-point reliable arithmetic.
+
+The MPFR library is a well-known portable C library for
+arbitrary-precision arithmetic on floating-point numbers. It provides
+precise control over precisions and rounding modes and gives
+correctly-rounded reproducible platform-independent results.
+
+The bigfloat module aims to provide a convenient and friendly Python
+interface to the operations and functions provided by the MPFR library.
+The main class, BigFloat, gives an immutable multiple-precision
+floating-point type that can be freely mixed with Python integers and
+floats. The Context class, when used in conjunction with Pythons with
+statement, gives a simple way of controlling precisions and rounding
+modes. Additional module-level functions provide various standard
+mathematical operations. There is full support for IEEE 754 signed
+zeros, nans, infinities and subnormals.
diff --git a/python/python2-bigfloat/doinst.sh b/python/python2-bigfloat/doinst.sh
new file mode 100644
index 0000000000..c9ae7e166c
--- /dev/null
+++ b/python/python2-bigfloat/doinst.sh
@@ -0,0 +1,3 @@
+#!/bin/bash
+
+python -m bigfloat.test.test_bigfloat
diff --git a/python/python2-bigfloat/python2-bigfloat.SlackBuild b/python/python2-bigfloat/python2-bigfloat.SlackBuild
new file mode 100644
index 0000000000..e41bde81d4
--- /dev/null
+++ b/python/python2-bigfloat/python2-bigfloat.SlackBuild
@@ -0,0 +1,71 @@
+#!/bin/sh
+
+# Slackware build script for python-bigfloat
+
+# Written by John Tyree <johntyree@gmail.com>
+
+PRGNAM=python2-bigfloat
+VERSION=${VERSION:-0.3.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM=$(echo $PRGNAM | cut -d- -f2)
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+mv $SRCNAM-$VERSION $PRGNAM-$VERSION
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python2 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING* *.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -p -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python2-bigfloat/python2-bigfloat.info b/python/python2-bigfloat/python2-bigfloat.info
new file mode 100644
index 0000000000..87ccd69016
--- /dev/null
+++ b/python/python2-bigfloat/python2-bigfloat.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-bigfloat"
+VERSION="0.3.0"
+HOMEPAGE="https://github.com/mdickinson/bigfloat/"
+DOWNLOAD="https://github.com/mdickinson/bigfloat/archive/v0.3.0/bigfloat-0.3.0.tar.gz"
+MD5SUM="fe976782d4c969f11b806e8ff2706d79"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="John Tyree"
+EMAIL="johntyree+removethis@gmail.com"
diff --git a/python/python2-bigfloat/slack-desc b/python/python2-bigfloat/slack-desc
new file mode 100644
index 0000000000..fc20de4ea8
--- /dev/null
+++ b/python/python2-bigfloat/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-bigfloat: python2-bigfloat (Arbitrary precision floating point arithmetic)
+python2-bigfloat:
+python2-bigfloat: The bigfloat module is a Python wrapper for the MPFR library for
+python2-bigfloat: arbitrary precision floating-point reliable arithmetic.
+python2-bigfloat:
+python2-bigfloat: The MPFR library is a well-known portable C library for
+python2-bigfloat: arbitrary-precision arithmetic on floating-point numbers. It provides
+python2-bigfloat: precise control over precisions and rounding modes and gives
+python2-bigfloat: correctly-rounded reproducible platform-independent results.
+python2-bigfloat:
+python2-bigfloat: