summaryrefslogtreecommitdiffstats
path: root/python/python-watchdog
diff options
context:
space:
mode:
author Isaac Yu2023-02-18 05:11:59 +0100
committer Willy Sudiarto Raharjo2023-02-18 10:44:14 +0100
commit1c95cfb1a4013b932ca39b66dbfa4bc0689f3e7c (patch)
treefb77a46f38cb7ce2cde17a0b3eb70e44a0c82f1c /python/python-watchdog
parent6ef39c1b994a0b3ae5b0e3a2d7e447402104b995 (diff)
downloadslackbuilds-1c95cfb1a4013b932ca39b66dbfa4bc0689f3e7c.tar.gz
python/python-watchdog: Removed (replaced by python3-watchdog)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python-watchdog')
-rw-r--r--python/python-watchdog/README1
-rw-r--r--python/python-watchdog/python-watchdog.SlackBuild82
-rw-r--r--python/python-watchdog/python-watchdog.info10
-rw-r--r--python/python-watchdog/slack-desc19
4 files changed, 0 insertions, 112 deletions
diff --git a/python/python-watchdog/README b/python/python-watchdog/README
deleted file mode 100644
index c91bfe7cd6..0000000000
--- a/python/python-watchdog/README
+++ /dev/null
@@ -1 +0,0 @@
-Python API and shell utilities to monitor file system events.
diff --git a/python/python-watchdog/python-watchdog.SlackBuild b/python/python-watchdog/python-watchdog.SlackBuild
deleted file mode 100644
index 9e3ef5bd5b..0000000000
--- a/python/python-watchdog/python-watchdog.SlackBuild
+++ /dev/null
@@ -1,82 +0,0 @@
-#!/bin/bash
-
-# SlackBuild build script for python-watchdog
-
-# Copyright (c) 2000-2020 Prof. Horstmann <wmh (at) eipg.fr>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=python-watchdog
-SRCPKG=${SRCPKG-watchdog}
-VERSION=${VERSION:-0.10.4}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-SRCNAM="$(printf $SRCPKG | cut -d- -f2-)"
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python2 setup.py install --root=$PKG
-python3 setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python-watchdog/python-watchdog.info b/python/python-watchdog/python-watchdog.info
deleted file mode 100644
index 0ff516f1a1..0000000000
--- a/python/python-watchdog/python-watchdog.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-watchdog"
-VERSION="0.10.4"
-HOMEPAGE="https://pypi.org/project/watchdog/"
-DOWNLOAD="https://files.pythonhosted.org/packages/6f/10/500580a0987363a0d9e1f3dd5cb1bba94a47e19266c6ce9dfb6cdd455758/watchdog-0.10.4.tar.gz"
-MD5SUM="d8fba5e25277520b65ca55952ae1341b"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="pathtools3"
-MAINTAINER="Pr. HORSTMANN"
-EMAIL="wmh@eipg.fr"
diff --git a/python/python-watchdog/slack-desc b/python/python-watchdog/slack-desc
deleted file mode 100644
index 4c8e2a7721..0000000000
--- a/python/python-watchdog/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-watchdog: python-watchdog (Filesystem events monitoring)
-python-watchdog:
-python-watchdog: Python API and shell utilities to monitor file system events.
-python-watchdog:
-python-watchdog: Works on Python 2.7 and 3.4+. If you want to use an old version of
-python-watchdog: Python, you should stick with python-watchdog < 0.10.0.
-python-watchdog:
-python-watchdog:
-python-watchdog:
-python-watchdog: Homepage: https://pypi.org/project/python-watchdog/
-python-watchdog: