summaryrefslogtreecommitdiffstats
path: root/python/python-slip/python-slip.SlackBuild
diff options
context:
space:
mode:
author Robby Workman2021-05-03 04:16:46 +0200
committer Robby Workman2021-05-03 04:16:46 +0200
commit6bfaa97182a98231563b408c0e8db74e2e3013c6 (patch)
tree019bd1593a429c4cec8c2f7cd50dc8df0bb7c764 /python/python-slip/python-slip.SlackBuild
parent856ad859cd0a1e22a6a886e9b453403594d657bc (diff)
downloadslackbuilds-6bfaa97182a98231563b408c0e8db74e2e3013c6.tar.gz
python/python-slip: Include support for python3
Diffstat (limited to 'python/python-slip/python-slip.SlackBuild')
-rw-r--r--python/python-slip/python-slip.SlackBuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/python/python-slip/python-slip.SlackBuild b/python/python-slip/python-slip.SlackBuild
index 6415665f3b..d551f00546 100644
--- a/python/python-slip/python-slip.SlackBuild
+++ b/python/python-slip/python-slip.SlackBuild
@@ -70,7 +70,8 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
sed -e 's/@VERSION@/0.6.5/g' setup.py.in > setup.py
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true