summaryrefslogtreecommitdiffstats
path: root/python/python-sh/python-sh.SlackBuild
diff options
context:
space:
mode:
author Larry Hajali2015-01-01 01:22:59 +0100
committer Willy Sudiarto Raharjo2015-01-01 01:22:59 +0100
commit29b4b8f46fd65c2b87c1589b18f9182bd819f405 (patch)
tree66564d3ed891508c7150dcd0c47f820e6ae58005 /python/python-sh/python-sh.SlackBuild
parent7630b7ec7f46385df2547a3e3607081ba2d53275 (diff)
downloadslackbuilds-29b4b8f46fd65c2b87c1589b18f9182bd819f405.tar.gz
python/python-sh: Updated for version 1.11.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python-sh/python-sh.SlackBuild')
-rw-r--r--python/python-sh/python-sh.SlackBuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/python/python-sh/python-sh.SlackBuild b/python/python-sh/python-sh.SlackBuild
index f79cd4519d..61c0b9ff78 100644
--- a/python/python-sh/python-sh.SlackBuild
+++ b/python/python-sh/python-sh.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-sh
-# Copyright 2012-2013 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2012-2015 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=python-sh
-VERSION=${VERSION:-1.09}
+VERSION=${VERSION:-1.11}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -50,20 +50,22 @@ tar xvf $CWD/${PRGNAM/python-/}-$VERSION.tar.gz
cd ${PRGNAM/python-/}-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
+if $(python3 -c 'import os' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS.md LICENSE.txt PKG-INFO README.md \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS.md LICENSE.txt PKG-INFO README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install