summaryrefslogtreecommitdiffstats
path: root/python/python-qrcode
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2018-01-04 02:20:32 +0100
committer Willy Sudiarto Raharjo2018-01-06 00:41:43 +0100
commitf563de6ae73d60cae0eedc15cb7ff3d3c970ffe2 (patch)
treecae0f832299fef4d6ce9a27d4246a81ed47315d5 /python/python-qrcode
parenta4e4e74313d7bac5a68340317f59c86dca8ee6b9 (diff)
downloadslackbuilds-f563de6ae73d60cae0eedc15cb7ff3d3c970ffe2.tar.gz
python/python-qrcode: Add python3 support.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python-qrcode')
-rw-r--r--python/python-qrcode/python-qrcode.SlackBuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/python/python-qrcode/python-qrcode.SlackBuild b/python/python-qrcode/python-qrcode.SlackBuild
index 5bd9cb9da2..f240f72f61 100644
--- a/python/python-qrcode/python-qrcode.SlackBuild
+++ b/python/python-qrcode/python-qrcode.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-qrcode
-# Copyright 2015-2016 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2015-2018 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -74,6 +74,10 @@ sed -i "s|share/man/man1|man/man1|" setup.py
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true