summaryrefslogtreecommitdiffstats
path: root/python/python-pcapy
diff options
context:
space:
mode:
author Brenton Earl2017-04-07 21:29:53 +0200
committer Willy Sudiarto Raharjo2017-04-08 01:57:50 +0200
commit1bbead7f183b79fe38445f0b5b0eca9f9dd37e77 (patch)
tree1d2c72c8956e108509efd383fdb09d95a80e613f /python/python-pcapy
parent26c46a55936a3f75364e8b3f6d234c3405a8ff97 (diff)
downloadslackbuilds-1bbead7f183b79fe38445f0b5b0eca9f9dd37e77.tar.gz
python/python-pcapy: Added (python extension module for libpcap).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python/python-pcapy')
-rw-r--r--python/python-pcapy/README5
-rw-r--r--python/python-pcapy/no-auto-docs-setup.py.diff15
-rw-r--r--python/python-pcapy/python-pcapy.SlackBuild90
-rw-r--r--python/python-pcapy/python-pcapy.info10
-rw-r--r--python/python-pcapy/slack-desc19
5 files changed, 139 insertions, 0 deletions
diff --git a/python/python-pcapy/README b/python/python-pcapy/README
new file mode 100644
index 0000000000..01ad8c3816
--- /dev/null
+++ b/python/python-pcapy/README
@@ -0,0 +1,5 @@
+Pcapy is a Python extension module that interfaces with the libpcap packet
+capture library. Pcapy enables python scripts to capture packets on the
+network. Pcapy is highly effective when used in conjunction with a
+packet-handling package such as Impacket, which is a collection of Python
+classes for constructing and dissecting network packets.
diff --git a/python/python-pcapy/no-auto-docs-setup.py.diff b/python/python-pcapy/no-auto-docs-setup.py.diff
new file mode 100644
index 0000000000..aa161a3470
--- /dev/null
+++ b/python/python-pcapy/no-auto-docs-setup.py.diff
@@ -0,0 +1,15 @@
+--- pcapy-0.11.1.orig/setup.py 2017-01-16 09:38:07.000000000 -0700
++++ pcapy-0.11.1/setup.py 2017-04-06 17:01:20.736516673 -0600
+@@ -79,8 +79,8 @@
+ library_dirs=library_dirs,
+ libraries=libraries)],
+ # scripts=['tests/pcapytests.py', 'tests/96pings.pcap'],
+- data_files=[
+- (os.path.join('share', 'doc', PACKAGE_NAME),
+- ['README', 'LICENSE', 'pcapy.html']),
+- ('tests', ['tests/pcapytests.py', 'tests/96pings.pcap'])]
++ #data_files=[
++ # (os.path.join('share', 'doc', PACKAGE_NAME),
++ # ['README', 'LICENSE', 'pcapy.html']),
++ # ('tests', ['tests/pcapytests.py', 'tests/96pings.pcap'])]
+ )
diff --git a/python/python-pcapy/python-pcapy.SlackBuild b/python/python-pcapy/python-pcapy.SlackBuild
new file mode 100644
index 0000000000..9cae5a4cad
--- /dev/null
+++ b/python/python-pcapy/python-pcapy.SlackBuild
@@ -0,0 +1,90 @@
+#!/bin/sh
+
+# Slackware build script for python-pcapy
+
+# Copyright 2017 Brenton Earl <brent@exitstatusone.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-pcapy
+SRCNAM=pcapy
+VERSION=${VERSION:-0.11.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# No need for tests to be installed
+# Copy docs to version specific docs dir later
+patch -p1 --verbose < $CWD/no-auto-docs-setup.py.diff
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README ChangeLog LICENSE pcapy.html $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-pcapy/python-pcapy.info b/python/python-pcapy/python-pcapy.info
new file mode 100644
index 0000000000..e16121abed
--- /dev/null
+++ b/python/python-pcapy/python-pcapy.info
@@ -0,0 +1,10 @@
+PRGNAM="python-pcapy"
+VERSION="0.11.1"
+HOMEPAGE="https://www.coresecurity.com/corelabs-research/open-source-tools/pcapy"
+DOWNLOAD="https://github.com/CoreSecurity/pcapy/archive/0.11.1/pcapy-0.11.1.tar.gz"
+MD5SUM="eb82db6abbffae1786c5bae51c951685"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Brenton Earl"
+EMAIL="brent@exitstatusone.com"
diff --git a/python/python-pcapy/slack-desc b/python/python-pcapy/slack-desc
new file mode 100644
index 0000000000..c17118037a
--- /dev/null
+++ b/python/python-pcapy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-pcapy: python-pcapy (python extension module for libpcap)
+python-pcapy:
+python-pcapy: Pcapy is a Python extension module that interfaces with the libpcap
+python-pcapy: packet capture library. Pcapy enables python scripts to capture
+python-pcapy: packets on the network.
+python-pcapy:
+python-pcapy: Home: https://github.com/CoreSecurity/pcapy
+python-pcapy:
+python-pcapy:
+python-pcapy:
+python-pcapy: