summaryrefslogtreecommitdiffstats
path: root/python/python-lastfm
diff options
context:
space:
mode:
author Robby Workman2011-03-16 07:13:49 +0100
committer Robby Workman2011-03-20 18:33:01 +0100
commit7a1b4848a3d34a263544fadf08178c91c12fbad0 (patch)
tree8987d0fc908e371dfa87445425f59c7514075b37 /python/python-lastfm
parent987d45e99a299c3b24418b2976e8ec9d5f3bf404 (diff)
downloadslackbuilds-7a1b4848a3d34a263544fadf08178c91c12fbad0.tar.gz
python/*: Moved a lot of Python stuff here
The criteria for whether something "belongs" in Development or Libraries or Python or ... is admittedly arbitrary. As a general rule, if it could be either Libraries or Python, it's Python. Otherwise, pick one and we'll go from there... Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python/python-lastfm')
-rw-r--r--python/python-lastfm/README2
-rw-r--r--python/python-lastfm/nostdeb.diff15
-rw-r--r--python/python-lastfm/python-lastfm.SlackBuild69
-rw-r--r--python/python-lastfm/python-lastfm.info10
-rw-r--r--python/python-lastfm/slack-desc19
5 files changed, 115 insertions, 0 deletions
diff --git a/python/python-lastfm/README b/python/python-lastfm/README
new file mode 100644
index 0000000000..f043600b95
--- /dev/null
+++ b/python/python-lastfm/README
@@ -0,0 +1,2 @@
+A python interface to the last.fm web services API. Its under development
+now and the code in SVN is incomplete.
diff --git a/python/python-lastfm/nostdeb.diff b/python/python-lastfm/nostdeb.diff
new file mode 100644
index 0000000000..83d1ea07bc
--- /dev/null
+++ b/python/python-lastfm/nostdeb.diff
@@ -0,0 +1,15 @@
+*** setup.py 2009-03-04 09:34:14.000000000 +0200
+--- setup1.py 2009-03-04 09:36:03.000000000 +0200
+***************
+*** 1,5 ****
+ #!/usr/bin/env python
+! import stdeb
+ __author__ = "Abhinav Sarkar <abhinav@abhinavsarkar.net>"
+ __version__ = "0.1"
+ __license__ = "GNU Lesser General Public License"
+--- 1,5 ----
+ #!/usr/bin/env python
+!
+ __author__ = "Abhinav Sarkar <abhinav@abhinavsarkar.net>"
+ __version__ = "0.1"
+ __license__ = "GNU Lesser General Public License"
diff --git a/python/python-lastfm/python-lastfm.SlackBuild b/python/python-lastfm/python-lastfm.SlackBuild
new file mode 100644
index 0000000000..9a8fde69f5
--- /dev/null
+++ b/python/python-lastfm/python-lastfm.SlackBuild
@@ -0,0 +1,69 @@
+#!/bin/sh
+
+# Slackware build script for python-lastfm
+
+# Written by Mihai Militaru <mihai.militaru@gmx.com>
+# March 2009
+
+PRGNAM=python-lastfm
+ORIGNAM=lastfm
+VERSION=${VERSION:-0.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$ORIGNAM-$VERSION.tar.gz
+cd $ORIGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+patch -p0 < $CWD/nostdeb.diff
+
+python setup.py install --root $PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-lastfm/python-lastfm.info b/python/python-lastfm/python-lastfm.info
new file mode 100644
index 0000000000..8cbb544aba
--- /dev/null
+++ b/python/python-lastfm/python-lastfm.info
@@ -0,0 +1,10 @@
+PRGNAM="python-lastfm"
+VERSION="0.1"
+HOMEPAGE="http://code.google.com/p/python-lastfm/"
+DOWNLOAD="http://python-lastfm.googlecode.com/svn/trunk/dist/lastfm-0.1.tar.gz"
+MD5SUM="11c85f85fd1bd3a73dbe80473609a151"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Mihai Militaru"
+EMAIL="mihai.militaru@gmx.com"
+APPROVED="dsomero"
diff --git a/python/python-lastfm/slack-desc b/python/python-lastfm/slack-desc
new file mode 100644
index 0000000000..463f7e833b
--- /dev/null
+++ b/python/python-lastfm/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------|
+python-lastfm: python-lastfm (python interface to last.fm)
+python-lastfm:
+python-lastfm: A python interface to the last.fm web services API. Its under
+python-lastfm: development now and the code in SVN is incomplete.
+python-lastfm:
+python-lastfm:
+python-lastfm:
+python-lastfm:
+python-lastfm: Homepage: http://code.google.com/p/python-lastfm/
+python-lastfm:
+python-lastfm: