summaryrefslogtreecommitdiffstats
path: root/python/python-keyring
diff options
context:
space:
mode:
author Dimitris Zlatanidis2023-12-21 17:53:03 +0100
committer Willy Sudiarto Raharjo2023-12-22 02:00:25 +0100
commitba2c48afdb47fe1881fdff344a1e6c3e15e2e7a6 (patch)
treeeaf6c8ffaf06f342824b8a052c9cc520f26c69af /python/python-keyring
parentd12f566df4900c495db08e94f5ab98faabef099b (diff)
downloadslackbuilds-ba2c48afdb47fe1881fdff344a1e6c3e15e2e7a6.tar.gz
python/python-keyring: Removed (replaced by python3-keyring).
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python-keyring')
-rw-r--r--python/python-keyring/README3
-rw-r--r--python/python-keyring/python-keyring.SlackBuild101
-rw-r--r--python/python-keyring/python-keyring.info10
-rw-r--r--python/python-keyring/slack-desc19
4 files changed, 0 insertions, 133 deletions
diff --git a/python/python-keyring/README b/python/python-keyring/README
deleted file mode 100644
index 5935c016f6..0000000000
--- a/python/python-keyring/README
+++ /dev/null
@@ -1,3 +0,0 @@
-The Python keyring lib provides a easy way to access the
-system keyring service from python. It can be used in any
-application that needs safe password storage.
diff --git a/python/python-keyring/python-keyring.SlackBuild b/python/python-keyring/python-keyring.SlackBuild
deleted file mode 100644
index b411492a22..0000000000
--- a/python/python-keyring/python-keyring.SlackBuild
+++ /dev/null
@@ -1,101 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for keyring
-
-# Copyright 2015-2019 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=python-keyring
-SRCNAM=$(echo $PRGNAM | cut -c8-14)
-VERSION=${VERSION:-19.2.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst CHANGES.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python-keyring/python-keyring.info b/python/python-keyring/python-keyring.info
deleted file mode 100644
index 9e52229853..0000000000
--- a/python/python-keyring/python-keyring.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-keyring"
-VERSION="19.2.0"
-HOMEPAGE="https://bitbucket.org/kang/python-keyring-lib"
-DOWNLOAD="https://files.pythonhosted.org/packages/ee/46/77fdb7cd2b0f1f684afbc35a59b3d7ebb6961fe528f97b86900002968914/keyring-19.2.0.tar.gz"
-MD5SUM="1eb6d586ee5794de4bf39c1f513a3139"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python2-setuptools-scm entrypoints secretstorage"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/python-keyring/slack-desc b/python/python-keyring/slack-desc
deleted file mode 100644
index ae136fec28..0000000000
--- a/python/python-keyring/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-keyring: python-keyring (Python keyring library)
-python-keyring:
-python-keyring: The Python keyring lib provides a easy way to access the system
-python-keyring: keyring service from python. It can be used in any application
-python-keyring: that needs safe password storage.
-python-keyring:
-python-keyring: Homepage: https://bitbucket.org/kang/python-keyring-lib
-python-keyring:
-python-keyring:
-python-keyring:
-python-keyring: