summaryrefslogtreecommitdiffstats
path: root/python/python-keyring/python-keyring.SlackBuild
diff options
context:
space:
mode:
author Dimitris Zlatanidis2016-05-20 18:24:19 +0200
committer Dimitris Zlatanidis2016-05-20 18:24:19 +0200
commitd1fcf1e3091a14ec9f310e650c747ca5df5b8df9 (patch)
treee8b9830337b94e69e67a342bb168fbee53c11f00 /python/python-keyring/python-keyring.SlackBuild
parentdf22aa9b5d800530b4666e21524cfdad09897dde (diff)
downloadslackbuilds-d1fcf1e3091a14ec9f310e650c747ca5df5b8df9.tar.gz
python/python-keyring: Add python3 support.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'python/python-keyring/python-keyring.SlackBuild')
-rw-r--r--python/python-keyring/python-keyring.SlackBuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/python/python-keyring/python-keyring.SlackBuild b/python/python-keyring/python-keyring.SlackBuild
index 2501513adf..04f79aa75d 100644
--- a/python/python-keyring/python-keyring.SlackBuild
+++ b/python/python-keyring/python-keyring.SlackBuild
@@ -72,6 +72,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true