summaryrefslogtreecommitdiffstats
path: root/python/python-cluster
diff options
context:
space:
mode:
author Robby Workman2011-03-16 07:13:49 +0100
committer Robby Workman2011-03-20 18:33:01 +0100
commit7a1b4848a3d34a263544fadf08178c91c12fbad0 (patch)
tree8987d0fc908e371dfa87445425f59c7514075b37 /python/python-cluster
parent987d45e99a299c3b24418b2976e8ec9d5f3bf404 (diff)
downloadslackbuilds-7a1b4848a3d34a263544fadf08178c91c12fbad0.tar.gz
python/*: Moved a lot of Python stuff here
The criteria for whether something "belongs" in Development or Libraries or Python or ... is admittedly arbitrary. As a general rule, if it could be either Libraries or Python, it's Python. Otherwise, pick one and we'll go from there... Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python/python-cluster')
-rw-r--r--python/python-cluster/README3
-rw-r--r--python/python-cluster/python-cluster.SlackBuild77
-rw-r--r--python/python-cluster/python-cluster.info10
-rw-r--r--python/python-cluster/slack-desc19
4 files changed, 109 insertions, 0 deletions
diff --git a/python/python-cluster/README b/python/python-cluster/README
new file mode 100644
index 0000000000..a074818a16
--- /dev/null
+++ b/python/python-cluster/README
@@ -0,0 +1,3 @@
+python-cluster is a package that allows grouping a list of arbitrary objects
+into related groups (clusters). Simply give it a list of data and a function
+to determine the similarity between two items and you're done.
diff --git a/python/python-cluster/python-cluster.SlackBuild b/python/python-cluster/python-cluster.SlackBuild
new file mode 100644
index 0000000000..fa065d91bc
--- /dev/null
+++ b/python/python-cluster/python-cluster.SlackBuild
@@ -0,0 +1,77 @@
+#!/bin/sh
+
+# Slackware build script for python-cluster.
+#
+# Copyright 2009-2010 Marco Bonetti <sid77@slackware.it>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-cluster
+SRCNAM=cluster
+VERSION=1.1.1b3
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="LICENSE PKG-INFO README"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar -xzvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-cluster/python-cluster.info b/python/python-cluster/python-cluster.info
new file mode 100644
index 0000000000..c099497716
--- /dev/null
+++ b/python/python-cluster/python-cluster.info
@@ -0,0 +1,10 @@
+PRGNAM="python-cluster"
+VERSION="1.1.1b3"
+HOMEPAGE="http://python-cluster.sourceforge.net/"
+DOWNLOAD="http://downloads.sourceforge.net/python-cluster/cluster-1.1.1b3.tar.gz"
+MD5SUM="a549edf712328540b08d394c79af2506"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Marco Bonetti"
+EMAIL="sid77@slackware.it"
+APPROVED="dsomero"
diff --git a/python/python-cluster/slack-desc b/python/python-cluster/slack-desc
new file mode 100644
index 0000000000..b60632f013
--- /dev/null
+++ b/python/python-cluster/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+python-cluster: python-cluster (allows grouping a list of arbitrary objects)
+python-cluster:
+python-cluster: python-cluster is a package that allows grouping a list of arbitrary
+python-cluster: objects into related groups (clusters). Simply give it a list of data
+python-cluster: and a function to determine the similarity between two items and
+python-cluster: you're done.
+python-cluster:
+python-cluster:
+python-cluster:
+python-cluster:
+python-cluster: