summaryrefslogtreecommitdiffstats
path: root/python/python-cheetah
diff options
context:
space:
mode:
author Nikos Skalkotos2011-07-08 22:51:04 +0200
committer Niels Horn2011-07-15 00:50:57 +0200
commit6a93398fdceb06d9d63313d045e8762dda40770b (patch)
tree61fe62f6a700eda0ea8d3b8efa451d4469c78dac /python/python-cheetah
parentab2766ddbc81b6376c4ab5cae1fef657112a2c51 (diff)
downloadslackbuilds-6a93398fdceb06d9d63313d045e8762dda40770b.tar.gz
python/python-cheetah: Added (Python-Powered Template Engine)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'python/python-cheetah')
-rw-r--r--python/python-cheetah/README8
-rw-r--r--python/python-cheetah/python-cheetah.SlackBuild73
-rw-r--r--python/python-cheetah/python-cheetah.info10
-rw-r--r--python/python-cheetah/slack-desc19
4 files changed, 110 insertions, 0 deletions
diff --git a/python/python-cheetah/README b/python/python-cheetah/README
new file mode 100644
index 0000000000..c4c01ca24b
--- /dev/null
+++ b/python/python-cheetah/README
@@ -0,0 +1,8 @@
+Cheetah is an open source template engine and code generation tool,
+written in Python. It can be used standalone or combined with other
+tools and frameworks. Web development is its principle use, but Cheetah
+is very flexible and is also being used to generate C++ game code, Java,
+sql, form emails and even Python code.
+
+The pysetuptools optional dependecy (available from SlackBuilds.org)
+enables outputting a markdown processed template.
diff --git a/python/python-cheetah/python-cheetah.SlackBuild b/python/python-cheetah/python-cheetah.SlackBuild
new file mode 100644
index 0000000000..ca07caa907
--- /dev/null
+++ b/python/python-cheetah/python-cheetah.SlackBuild
@@ -0,0 +1,73 @@
+#!/bin/sh
+
+# Slackware build script for python-cheetah
+
+# Written by Nikos Skalkotos (skalkoto@gmail.com)
+
+PRGNAM="python-cheetah"
+VERSION=${VERSION:-2.4.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM=Cheetah
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar -xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGES LICENSE TODO PKG-INFO README.markdown\
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+
diff --git a/python/python-cheetah/python-cheetah.info b/python/python-cheetah/python-cheetah.info
new file mode 100644
index 0000000000..c93632bc9d
--- /dev/null
+++ b/python/python-cheetah/python-cheetah.info
@@ -0,0 +1,10 @@
+PRGNAM="python-cheetah"
+VERSION="2.4.4"
+HOMEPAGE="http://www.cheetahtemplate.org/"
+DOWNLOAD="http://pypi.python.org/packages/source/C/Cheetah/Cheetah-2.4.4.tar.gz"
+MD5SUM="853917116e731afbc8c8a43c37e6ddba"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Nikos Skalkotos"
+EMAIL="skalkoto@gmail.com"
+APPROVED="Niels Horn"
diff --git a/python/python-cheetah/slack-desc b/python/python-cheetah/slack-desc
new file mode 100644
index 0000000000..f2354493c8
--- /dev/null
+++ b/python/python-cheetah/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+python-cheetah: Cheetah (Python-Powered Template Engine)
+python-cheetah:
+python-cheetah: Cheetah is an open source template engine and code generation tool,
+python-cheetah: written in Python. It can be used standalone or combined with other
+python-cheetah: tools and frameworks. Web development is its principle use, but
+python-cheetah: Cheetah is very flexible and is also being used to generate C++ game
+python-cheetah: code, Java, sql, form emails and even Python code.
+python-cheetah:
+python-cheetah: Homepage: http://www.cheetahtemplate.org/
+python-cheetah:
+python-cheetah: