summaryrefslogtreecommitdiffstats
path: root/python/pysed/pysed.SlackBuild
diff options
context:
space:
mode:
author Dimitris Zlatanidis2015-04-11 06:38:00 +0200
committer Willy Sudiarto Raharjo2015-04-12 05:06:48 +0200
commit371776a9a65172e8053f5a9831993e1737a5a4d3 (patch)
tree51e71ce94eed1ad5469622a9f6f0721e0453749d /python/pysed/pysed.SlackBuild
parente5c4592d4b167af57a9fc36b1e88a68c9a1be695 (diff)
downloadslackbuilds-371776a9a65172e8053f5a9831993e1737a5a4d3.tar.gz
python/pysed: Updated for version 0.6.2.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'python/pysed/pysed.SlackBuild')
-rw-r--r--python/pysed/pysed.SlackBuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/python/pysed/pysed.SlackBuild b/python/pysed/pysed.SlackBuild
index d578525e60..2cfbeb4a2d 100644
--- a/python/pysed/pysed.SlackBuild
+++ b/python/pysed/pysed.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pysed
-# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# Copyright 2014 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pysed
-VERSION=${VERSION:-0.3.1}
+VERSION=${VERSION:-0.6.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,11 +69,19 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# avoid install man page over setup.py
+sed -i 's/if "install"/if ""/' setup.py
+
python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# install man page
+mkdir -p $PKG/usr/man/man1
+gzip -9 man/$PRGNAM.1
+install -D -m0644 man/$PRGNAM.1.gz $PKG/usr/man/man1/$PRGNAM.1.gz
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README.rst CHANGELOG LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild