summaryrefslogtreecommitdiffstats
path: root/python/pymysql
diff options
context:
space:
mode:
author Dave Woodfall2021-05-21 22:32:21 +0200
committer Willy Sudiarto Raharjo2021-06-01 20:02:27 +0200
commit4e05370dffedbddc6de94098e836000c42da7087 (patch)
tree0349b32af788725dd5a1f354f276581bc8b44279 /python/pymysql
parent31cebe6ee687395dca31d4e48fb32479c4c01314 (diff)
downloadslackbuilds-4e05370dffedbddc6de94098e836000c42da7087.tar.gz
python/pymysql: Convert python to python2.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/pymysql')
-rw-r--r--python/pymysql/README9
-rw-r--r--python/pymysql/pymysql.SlackBuild8
2 files changed, 5 insertions, 12 deletions
diff --git a/python/pymysql/README b/python/pymysql/README
index 62679503c4..769bb96f27 100644
--- a/python/pymysql/README
+++ b/python/pymysql/README
@@ -1,6 +1,3 @@
-This package contains a pure-Python MySQL client library. The goal of PyMySQL is
-to be a drop-in replacement for MySQLdb and work on CPython, PyPy, IronPython
-and Jython.
-
-To install python3 bindings run slackbuild with option PYTHON3=yes.
- # PYTHON3=yes ./pymysql.SlackBuild
+This package contains a pure-Python MySQL client library. The goal of
+PyMySQL is to be a drop-in replacement for MySQLdb and work on CPython,
+PyPy, IronPython and Jython.
diff --git a/python/pymysql/pymysql.SlackBuild b/python/pymysql/pymysql.SlackBuild
index 5394c53c85..7ccd6a9852 100644
--- a/python/pymysql/pymysql.SlackBuild
+++ b/python/pymysql/pymysql.SlackBuild
@@ -56,12 +56,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-# Install python3 bindings. Default is no.
-if [ "${PYTHON3:-no}" == "yes" ]; then
- python3 setup.py install --root=$PKG
-fi
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true