summaryrefslogtreecommitdiffstats
path: root/python/pylirc
diff options
context:
space:
mode:
author Robby Workman2011-03-16 07:13:49 +0100
committer Robby Workman2011-03-20 18:33:01 +0100
commit7a1b4848a3d34a263544fadf08178c91c12fbad0 (patch)
tree8987d0fc908e371dfa87445425f59c7514075b37 /python/pylirc
parent987d45e99a299c3b24418b2976e8ec9d5f3bf404 (diff)
downloadslackbuilds-7a1b4848a3d34a263544fadf08178c91c12fbad0.tar.gz
python/*: Moved a lot of Python stuff here
The criteria for whether something "belongs" in Development or Libraries or Python or ... is admittedly arbitrary. As a general rule, if it could be either Libraries or Python, it's Python. Otherwise, pick one and we'll go from there... Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python/pylirc')
-rw-r--r--python/pylirc/README4
-rw-r--r--python/pylirc/pylirc.SlackBuild68
-rw-r--r--python/pylirc/pylirc.info10
-rw-r--r--python/pylirc/slack-desc19
4 files changed, 101 insertions, 0 deletions
diff --git a/python/pylirc/README b/python/pylirc/README
new file mode 100644
index 0000000000..4892569e50
--- /dev/null
+++ b/python/pylirc/README
@@ -0,0 +1,4 @@
+pyLirc is a module for Python that interacts with lirc to give Python
+programs the ability to receive commands from remote controls.
+
+This requires lirc.
diff --git a/python/pylirc/pylirc.SlackBuild b/python/pylirc/pylirc.SlackBuild
new file mode 100644
index 0000000000..d5e98c03d7
--- /dev/null
+++ b/python/pylirc/pylirc.SlackBuild
@@ -0,0 +1,68 @@
+#!/bin/sh
+
+# Slackware build script for pylirc
+
+# Written by Pablo Santamaria (pablosantamaria@gmail.com)
+
+PRGNAM=pylirc
+VERSION=${VERSION:-0.0.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+# Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pylirc/pylirc.info b/python/pylirc/pylirc.info
new file mode 100644
index 0000000000..c4a80504b6
--- /dev/null
+++ b/python/pylirc/pylirc.info
@@ -0,0 +1,10 @@
+PRGNAM="pylirc"
+VERSION="0.0.5"
+HOMEPAGE="http://pylirc.mccabe.nu/"
+DOWNLOAD="http://downloads.sourceforge.net/sourceforge/pylirc/pylirc-0.0.5.tar.gz"
+MD5SUM="4e3b6b50485610e273fededdb25b47ad"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Pablo Santamaria"
+EMAIL="pablosantamaria@gmail.com"
+APPROVED="dsomero"
diff --git a/python/pylirc/slack-desc b/python/pylirc/slack-desc
new file mode 100644
index 0000000000..b49da3fd03
--- /dev/null
+++ b/python/pylirc/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pylirc: pylirc (Python lirc module)
+pylirc:
+pylirc: pyLirc is a module for Python that interacts with lirc to give Python
+pylirc: programs the ability to receive commands from remote controls.
+pylirc:
+pylirc:
+pylirc:
+pylirc:
+pylirc:
+pylirc:
+pylirc: