summaryrefslogtreecommitdiffstats
path: root/python/pyliblo
diff options
context:
space:
mode:
author B. Watson2012-04-30 02:59:44 +0200
committer Erik Hanson2012-04-30 07:40:08 +0200
commitad76b106b43ed49fd572774bd782c6354ec5c443 (patch)
tree092464447aad7abd31df1019dd2f4df80664a790 /python/pyliblo
parentdfbdc37ef6bd88dc64ce101eb0065cd326dbf98d (diff)
downloadslackbuilds-ad76b106b43ed49fd572774bd782c6354ec5c443.tar.gz
python/pyliblo: Added (python wrapper for the liblo OSC library)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'python/pyliblo')
-rw-r--r--python/pyliblo/README9
-rw-r--r--python/pyliblo/pyliblo.SlackBuild72
-rw-r--r--python/pyliblo/pyliblo.info10
-rw-r--r--python/pyliblo/slack-desc19
4 files changed, 110 insertions, 0 deletions
diff --git a/python/pyliblo/README b/python/pyliblo/README
new file mode 100644
index 0000000000..15b05f7486
--- /dev/null
+++ b/python/pyliblo/README
@@ -0,0 +1,9 @@
+pyliblo (python wrapper for the liblo OSC library)
+
+pyliblo is a Python wrapper for the liblo Open Sound Control library. It
+supports almost the complete functionality of liblo, allowing you to
+send and receive OSC messages using a nice and simple Python API.
+
+Also included are the command line utilities send_osc and dump_osc.
+
+This requires liblo.
diff --git a/python/pyliblo/pyliblo.SlackBuild b/python/pyliblo/pyliblo.SlackBuild
new file mode 100644
index 0000000000..7292230274
--- /dev/null
+++ b/python/pyliblo/pyliblo.SlackBuild
@@ -0,0 +1,72 @@
+#!/bin/sh
+
+# Slackware build script for pyliblo
+
+# Written by B. Watson (yalhcru@gmail.com)
+
+PRGNAM=pyliblo
+VERSION=${VERSION:-0.9.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mv $PKG/usr/share/man $PKG/usr/man
+rmdir $PKG/usr/share
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING NEWS PKG-INFO README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pyliblo/pyliblo.info b/python/pyliblo/pyliblo.info
new file mode 100644
index 0000000000..6a5ea35891
--- /dev/null
+++ b/python/pyliblo/pyliblo.info
@@ -0,0 +1,10 @@
+PRGNAM="pyliblo"
+VERSION="0.9.1"
+HOMEPAGE="http://das.nasophon.de/pyliblo/"
+DOWNLOAD="http://das.nasophon.de/download/pyliblo-0.9.1.tar.gz"
+MD5SUM="eb2b2b86031b702eba8e65da75fbaacc"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"
+APPROVED="dsomero"
diff --git a/python/pyliblo/slack-desc b/python/pyliblo/slack-desc
new file mode 100644
index 0000000000..fdfd7fb5e8
--- /dev/null
+++ b/python/pyliblo/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+pyliblo: pyliblo (python wrapper for the liblo OSC library)
+pyliblo:
+pyliblo: pyliblo is a Python wrapper for the liblo Open Sound Control
+pyliblo: library. It supports almost the complete functionality of liblo,
+pyliblo: allowing you to send and receive OSC messages using a nice and simple
+pyliblo: Python API.
+pyliblo:
+pyliblo: Also included are the command line utilities send_osc and dump_osc.
+pyliblo:
+pyliblo:
+pyliblo: