summaryrefslogtreecommitdiffstats
path: root/python/pyfltk
diff options
context:
space:
mode:
author Robby Workman2011-03-16 07:13:49 +0100
committer Robby Workman2011-03-20 18:33:01 +0100
commit7a1b4848a3d34a263544fadf08178c91c12fbad0 (patch)
tree8987d0fc908e371dfa87445425f59c7514075b37 /python/pyfltk
parent987d45e99a299c3b24418b2976e8ec9d5f3bf404 (diff)
downloadslackbuilds-7a1b4848a3d34a263544fadf08178c91c12fbad0.tar.gz
python/*: Moved a lot of Python stuff here
The criteria for whether something "belongs" in Development or Libraries or Python or ... is admittedly arbitrary. As a general rule, if it could be either Libraries or Python, it's Python. Otherwise, pick one and we'll go from there... Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python/pyfltk')
-rw-r--r--python/pyfltk/README4
-rw-r--r--python/pyfltk/pyfltk.SlackBuild89
-rw-r--r--python/pyfltk/pyfltk.info10
-rw-r--r--python/pyfltk/slack-desc19
4 files changed, 122 insertions, 0 deletions
diff --git a/python/pyfltk/README b/python/pyfltk/README
new file mode 100644
index 0000000000..511b55f79d
--- /dev/null
+++ b/python/pyfltk/README
@@ -0,0 +1,4 @@
+PyFLTK provides a convenient wrapper for the FLTK GUI library for use in
+Python programs.
+
+This requires fltk.
diff --git a/python/pyfltk/pyfltk.SlackBuild b/python/pyfltk/pyfltk.SlackBuild
new file mode 100644
index 0000000000..b6223fec46
--- /dev/null
+++ b/python/pyfltk/pyfltk.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+
+# Slackware build script for pyfltk
+
+# Copyright 2006-2010 LukenShiro <lukenshiro@ngi.it>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pyfltk
+VERSION=${VERSION:-1.1.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+SRC_PRGNAM=pyFltk
+DOCFILES="CHANGES PKG-INFO INSTALL TODO COPYING README"
+
+# html files are now located in fltk/ subdirectory
+HTMLDOCS="fltk/docs/*"
+
+set -e
+
+# SLKCFLAGS are not necessary, it builds using fltk-config flags
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRC_PRGNAM-$VERSION
+tar -xvf $CWD/$SRC_PRGNAM-$VERSION.tar.gz
+cd $SRC_PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+# Copy documentation files
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+# Move html files and python test examples in order to preserve and install them
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/docs
+mv $HTMLDOCS $PKG/usr/doc/$PRGNAM-$VERSION/docs/
+
+# build from swig interface files
+cd python
+python ./MakeSwig.py
+
+cd $TMP/$SRC_PRGNAM-$VERSION
+python setup.py build
+# --install-data= flag is ignored now
+python setup.py install --prefix=/usr/ --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pyfltk/pyfltk.info b/python/pyfltk/pyfltk.info
new file mode 100644
index 0000000000..534bd4b338
--- /dev/null
+++ b/python/pyfltk/pyfltk.info
@@ -0,0 +1,10 @@
+PRGNAM="pyfltk"
+VERSION="1.1.5"
+HOMEPAGE="http://pyfltk.sourceforge.net/"
+DOWNLOAD="http://downloads.sourceforge.net/pyfltk/pyFltk-1.1.5.tar.gz"
+MD5SUM="3250ea44a184d28178aad845de11c6bb"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="LukenShiro"
+EMAIL="lukenshiro@ngi.it"
+APPROVED="dsomero"
diff --git a/python/pyfltk/slack-desc b/python/pyfltk/slack-desc
new file mode 100644
index 0000000000..5cea104fb7
--- /dev/null
+++ b/python/pyfltk/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler--------------------------------------------------------|
+pyfltk: pyfltk (FLTK Bindings for Python)
+pyfltk:
+pyfltk: PyFLTK provides a convenient wrapper for the FLTK GUI library for use
+pyfltk: in Python programs. It is now written by Andreas Held.
+pyfltk:
+pyfltk:
+pyfltk:
+pyfltk:
+pyfltk:
+pyfltk: Homepage: http://pyfltk.sourceforge.net/
+pyfltk: