summaryrefslogtreecommitdiffstats
path: root/python/pydblite
diff options
context:
space:
mode:
author LukenShiro2011-12-14 23:31:10 +0100
committer Niels Horn2011-12-18 03:07:50 +0100
commit0071155ccdec7c91315f8fa2740807f85a0dcd0a (patch)
tree2f9bf42c973edf013fbb332b121813b34bb90209 /python/pydblite
parent66f8ada4ceb4c8bbe4053201864c28e6e1e1a57f (diff)
downloadslackbuilds-0071155ccdec7c91315f8fa2740807f85a0dcd0a.tar.gz
python/pydblite: Moved from Development (updated to version 2.7).
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python/pydblite')
-rw-r--r--python/pydblite/README8
-rw-r--r--python/pydblite/pydblite.SlackBuild73
-rw-r--r--python/pydblite/pydblite.info10
-rw-r--r--python/pydblite/slack-desc19
4 files changed, 110 insertions, 0 deletions
diff --git a/python/pydblite/README b/python/pydblite/README
new file mode 100644
index 0000000000..00a37b1a68
--- /dev/null
+++ b/python/pydblite/README
@@ -0,0 +1,8 @@
+PyDbLite (small footprint untyped database engine in python)
+
+PyDbLite is a pure-Python in-memory database engine, using Python
+list comprehensions as query language instead of SQL, which stores
+data in a cPickled file.
+
+You can also use PyDbLite with MySQL and SQLite, as backends.
+In order to use MySQL's adapter, you will need MySQL-python.
diff --git a/python/pydblite/pydblite.SlackBuild b/python/pydblite/pydblite.SlackBuild
new file mode 100644
index 0000000000..ea657bb32c
--- /dev/null
+++ b/python/pydblite/pydblite.SlackBuild
@@ -0,0 +1,73 @@
+#!/bin/sh
+
+# Slackware build script for pydblite
+
+# Copyright 2007-2011 LukenShiro, Italy
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pydblite
+VERSION=${VERSION:-2.7}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+SRCNAM=PyDbLite
+DOCFILES="PKG-INFO README.txt LICENCE.txt doc/*"
+
+# SLKCFLAGS are not used
+
+set -e # Exit on most errors
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+unzip $CWD/$SRCNAM-$VERSION.zip
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py build install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pydblite/pydblite.info b/python/pydblite/pydblite.info
new file mode 100644
index 0000000000..b3c0f82610
--- /dev/null
+++ b/python/pydblite/pydblite.info
@@ -0,0 +1,10 @@
+PRGNAM="pydblite"
+VERSION="2.7"
+HOMEPAGE="http://pydblite.sourceforge.net"
+DOWNLOAD="http://downloads.sourceforge.net/pydblite/PyDbLite-2.7.zip"
+MD5SUM="6d7d71a01ae5731a515ea3e6552cd843"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="LukenShiro"
+EMAIL="lukenshiro@ngi.it"
+APPROVED="rworkman"
diff --git a/python/pydblite/slack-desc b/python/pydblite/slack-desc
new file mode 100644
index 0000000000..5a2e5392ae
--- /dev/null
+++ b/python/pydblite/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+pydblite: PyDbLite (small footprint untyped database engine in python)
+pydblite:
+pydblite: PyDbLite is a pure-Python in-memory database engine, using
+pydblite: Python list comprehensions as query language instead of SQL,
+pydblite: which stores data in a cPickled file.
+pydblite:
+pydblite: It is written by Pierre Quentel and released under BSD license.
+pydblite:
+pydblite: Homepage: http://pydblite.sourceforge.net
+pydblite:
+pydblite: