summaryrefslogtreecommitdiffstats
path: root/python/pycryptodomex
diff options
context:
space:
mode:
author Dave Woodfall2021-05-21 22:32:20 +0200
committer Willy Sudiarto Raharjo2021-06-01 20:02:27 +0200
commitc99731af6e8551218c0d4f3b23206974e4f42a9f (patch)
tree5dd6918b9a37a9282e1174a3e095c779102138ce /python/pycryptodomex
parent243c6545f682a4f9454673a0f4ce9749e1dc0f68 (diff)
downloadslackbuilds-c99731af6e8551218c0d4f3b23206974e4f42a9f.tar.gz
python/pycryptodomex: Convert python to python2.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/pycryptodomex')
-rw-r--r--python/pycryptodomex/README14
-rw-r--r--python/pycryptodomex/pycryptodomex.SlackBuild9
-rw-r--r--python/pycryptodomex/pycryptodomex.info2
3 files changed, 11 insertions, 14 deletions
diff --git a/python/pycryptodomex/README b/python/pycryptodomex/README
index 7b818930c5..8aa5026945 100644
--- a/python/pycryptodomex/README
+++ b/python/pycryptodomex/README
@@ -1,8 +1,8 @@
-PyCryptodome is a self-contained Python package of low-level cryptographic
-primitives. It supports Python 2.6 or newer, all Python 3 versions and PyPy.
-PyCryptodome is a fork of PyCrypto.
+PyCryptodome is a self-contained Python package of low-level
+cryptographic primitives. It supports Python 2.6 or newer, all Python 3
+versions and PyPy. PyCryptodome is a fork of PyCrypto.
-PyCryptodome is not a wrapper to a separate C library like OpenSSL. To the
-largest possible extent, algorithms are implemented in pure Python. Only the
-pieces that are extremely critical to performance (e.g. block ciphers) are
-implemented as C extensions.
+PyCryptodome is not a wrapper to a separate C library like OpenSSL. To
+the largest possible extent, algorithms are implemented in pure Python.
+Only the pieces that are extremely critical to performance (e.g. block
+ciphers) are implemented as C extensions.
diff --git a/python/pycryptodomex/pycryptodomex.SlackBuild b/python/pycryptodomex/pycryptodomex.SlackBuild
index 453938d520..550d8775b6 100644
--- a/python/pycryptodomex/pycryptodomex.SlackBuild
+++ b/python/pycryptodomex/pycryptodomex.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=pycryptodomex
VERSION=${VERSION:-3.10.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -69,11 +69,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/pycryptodomex/pycryptodomex.info b/python/pycryptodomex/pycryptodomex.info
index 405c0cc46b..87036aaef8 100644
--- a/python/pycryptodomex/pycryptodomex.info
+++ b/python/pycryptodomex/pycryptodomex.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://github.com/Legrandin/pycryptodome/archive/v3.10.1x/pycryptodom
MD5SUM="a5c0aafa12b0a4643728309a1bae1e4d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="setuptools-scm"
MAINTAINER="Markus Rinne"
EMAIL="markus.ka.rinne@gmail.com"