summaryrefslogtreecommitdiffstats
path: root/python/pycrypto
diff options
context:
space:
mode:
author Heinz Wiesinger2011-03-30 16:24:39 +0200
committer Robby Workman2011-03-31 05:52:58 +0200
commitebb7fab98ddd387511cac524f468a2c8936b87de (patch)
tree84fb7fb731c8eeeae9efcc0a309c2584e0afbd87 /python/pycrypto
parent09d5f75042eae044bea7efedfa9da3d1bc77dce5 (diff)
downloadslackbuilds-ebb7fab98ddd387511cac524f468a2c8936b87de.tar.gz
python/pycrypto: Moved from /development and updated for version 2.3
Signed-off-by: Heinz Wiesinger <pprkut@slackbuilds.org>
Diffstat (limited to 'python/pycrypto')
-rw-r--r--python/pycrypto/README3
-rw-r--r--python/pycrypto/pycrypto.SlackBuild72
-rw-r--r--python/pycrypto/pycrypto.info10
-rw-r--r--python/pycrypto/slack-desc19
4 files changed, 104 insertions, 0 deletions
diff --git a/python/pycrypto/README b/python/pycrypto/README
new file mode 100644
index 0000000000..ed20575779
--- /dev/null
+++ b/python/pycrypto/README
@@ -0,0 +1,3 @@
+This is a collection of both secure hash functions (such as MD5 and SHA),
+and various encryption algorithms (AES, DES, IDEA, RSA, ElGamal, etc.).
+The package is structured to make adding new modules easy.
diff --git a/python/pycrypto/pycrypto.SlackBuild b/python/pycrypto/pycrypto.SlackBuild
new file mode 100644
index 0000000000..71d0804791
--- /dev/null
+++ b/python/pycrypto/pycrypto.SlackBuild
@@ -0,0 +1,72 @@
+#!/bin/sh
+
+# Slackware build script for pycrypto
+
+# Copyright 2008-2011 Heinz Wiesinger, Amsterdam, The Netherlands
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pycrypto
+VERSION=2.3
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a ACKS ChangeLog COPYRIGHT README TODO Doc \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pycrypto/pycrypto.info b/python/pycrypto/pycrypto.info
new file mode 100644
index 0000000000..3d539a82e8
--- /dev/null
+++ b/python/pycrypto/pycrypto.info
@@ -0,0 +1,10 @@
+PRGNAM="pycrypto"
+VERSION="2.3"
+HOMEPAGE="http://www.pycrypto.org"
+DOWNLOAD="http://ftp.dlitz.net/pub/dlitz/crypto/pycrypto/pycrypto-2.3.tar.gz"
+MD5SUM="2b811cfbfc342d83ee614097effb8101"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Heinz Wiesinger"
+EMAIL="pprkut@liwjatan.at"
+APPROVED="Erik Hanson"
diff --git a/python/pycrypto/slack-desc b/python/pycrypto/slack-desc
new file mode 100644
index 0000000000..2677aedac8
--- /dev/null
+++ b/python/pycrypto/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler----------------------------------------------------|
+pycrypto: pycrypto (Python Cryptography Toolkit)
+pycrypto:
+pycrypto: This is a collection of both secure hash functions (such as MD5 and
+pycrypto: SHA), and various encryption algorithms (AES, DES, IDEA, RSA,
+pycrypto: ElGamal, etc.). The package is structured to make adding new
+pycrypto: modules easy.
+pycrypto:
+pycrypto: Homepage: http://www.pycrypto.org
+pycrypto:
+pycrypto:
+pycrypto: