summaryrefslogtreecommitdiffstats
path: root/python/pycassa
diff options
context:
space:
mode:
author Nikolay Korotkiy2012-12-28 23:01:51 +0100
committer Matteo Bernardini2012-12-28 23:02:06 +0100
commit2652e7514b336e07869fb1ac0066bd8b22338f4c (patch)
tree78341cf1705eda3c28445f816109be913820eec3 /python/pycassa
parentc10597536efd3458796d89addc04f672285e0807 (diff)
downloadslackbuilds-2652e7514b336e07869fb1ac0066bd8b22338f4c.tar.gz
python/pycassa: Added (client library for Apache Cassandra).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'python/pycassa')
-rw-r--r--python/pycassa/README10
-rw-r--r--python/pycassa/pycassa.SlackBuild70
-rw-r--r--python/pycassa/pycassa.info10
-rw-r--r--python/pycassa/slack-desc19
4 files changed, 109 insertions, 0 deletions
diff --git a/python/pycassa/README b/python/pycassa/README
new file mode 100644
index 0000000000..4c9b71a4e2
--- /dev/null
+++ b/python/pycassa/README
@@ -0,0 +1,10 @@
+pycassa is a python client library for Apache Cassandra with
+the following features:
+
+ - Automatic failover and operation retries
+ - Connection pooling
+ - Multithreading support
+ - A batch interface
+ - A class for mapping classes to Cassandra column families
+
+pycassa is open source under the MIT license.
diff --git a/python/pycassa/pycassa.SlackBuild b/python/pycassa/pycassa.SlackBuild
new file mode 100644
index 0000000000..41493a8b05
--- /dev/null
+++ b/python/pycassa/pycassa.SlackBuild
@@ -0,0 +1,70 @@
+#!/bin/sh
+
+# Slackware build script for pycassa
+
+# Copyright 2012, Nikolay Korotkiy <sikmir@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pycassa
+VERSION=${VERSION:-1.7.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -eu
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS CHANGES LICENSE README.mkd $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pycassa/pycassa.info b/python/pycassa/pycassa.info
new file mode 100644
index 0000000000..b4d17c3260
--- /dev/null
+++ b/python/pycassa/pycassa.info
@@ -0,0 +1,10 @@
+PRGNAM="pycassa"
+VERSION="1.7.2"
+HOMEPAGE="https://github.com/pycassa/pycassa"
+DOWNLOAD="https://github.com/downloads/pycassa/pycassa/pycassa-1.7.2.tar.gz"
+MD5SUM="aa69935198b39fb72a2969401180ddc8"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="thrift"
+MAINTAINER="Nikolay Korotkiy"
+EMAIL="sikmir@gmail.com"
diff --git a/python/pycassa/slack-desc b/python/pycassa/slack-desc
new file mode 100644
index 0000000000..6812d77737
--- /dev/null
+++ b/python/pycassa/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pycassa: pycassa (python client library for Apache Cassandra)
+pycassa:
+pycassa: - Automatic failover and operation retries
+pycassa: - Connection pooling
+pycassa: - Multithreading support
+pycassa: - A batch interface
+pycassa: - A class for mapping classes to Cassandra column families
+pycassa:
+pycassa: Homepage: https://github.com/pycassa
+pycassa:
+pycassa: