summaryrefslogtreecommitdiffstats
path: root/python/pyamf
diff options
context:
space:
mode:
author Markus Rinne2017-11-05 22:42:12 +0100
committer David Spencer2017-11-05 22:42:12 +0100
commita795a091c9906cdd74c92c36374eee973f1385a6 (patch)
tree56022822b95dead9cdfe7860ae0594f107b24bc7 /python/pyamf
parent3af4184c45cf58a765f4c6cf314d786cd8019765 (diff)
downloadslackbuilds-a795a091c9906cdd74c92c36374eee973f1385a6.tar.gz
python/pyamf: Added (Action Message Format support for Python).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python/pyamf')
-rw-r--r--python/pyamf/README3
-rw-r--r--python/pyamf/pyamf.SlackBuild87
-rw-r--r--python/pyamf/pyamf.info10
-rw-r--r--python/pyamf/slack-desc19
4 files changed, 119 insertions, 0 deletions
diff --git a/python/pyamf/README b/python/pyamf/README
new file mode 100644
index 0000000000..8f6991714e
--- /dev/null
+++ b/python/pyamf/README
@@ -0,0 +1,3 @@
+PyAMF provides Action Message Format (AMF) support for Python that is
+compatible with the Adobe Flash Player. It includes integration with Python
+web frameworks like Django, Pylons, Twisted, SQLAlchemy, web2py and more.
diff --git a/python/pyamf/pyamf.SlackBuild b/python/pyamf/pyamf.SlackBuild
new file mode 100644
index 0000000000..7dc9769e44
--- /dev/null
+++ b/python/pyamf/pyamf.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/sh
+
+# Slackware build script for pyamf
+
+# Copyright 2017 Markus Rinne Finland
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pyamf
+VERSION=${VERSION:-0.8.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGES.txt LICENSE.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pyamf/pyamf.info b/python/pyamf/pyamf.info
new file mode 100644
index 0000000000..8ee7aea5ee
--- /dev/null
+++ b/python/pyamf/pyamf.info
@@ -0,0 +1,10 @@
+PRGNAM="pyamf"
+VERSION="0.8.0"
+HOMEPAGE="https://github.com/hydralabs/pyamf"
+DOWNLOAD="https://github.com/hydralabs/pyamf/archive/v0.8.0/pyamf-0.8.0.tar.gz"
+MD5SUM="9ab2772c9f255b6e17cc2fa0e1073ff3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="defusedxml"
+MAINTAINER="Markus Rinne"
+EMAIL="markus.ka.rinne@gmail.com"
diff --git a/python/pyamf/slack-desc b/python/pyamf/slack-desc
new file mode 100644
index 0000000000..0d75d03b7b
--- /dev/null
+++ b/python/pyamf/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pyamf: pyamf (Action Message Format support for Python)
+pyamf:
+pyamf: PyAMF provides Action Message Format (AMF) support for Python that is
+pyamf: compatible with the Adobe Flash Player. It includes integration with
+pyamf: Python web frameworks like Django, Pylons, Twisted, SQLAlchemy,
+pyamf: web2py and more.
+pyamf:
+pyamf:
+pyamf:
+pyamf:
+pyamf: