summaryrefslogtreecommitdiffstats
path: root/python/ptyprocess
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2022-05-11 15:40:17 +0200
committer Willy Sudiarto Raharjo2022-05-14 14:27:49 +0200
commit067cee2dd85635080283ca6ed0cbd25d47c8acb2 (patch)
tree9ad9d52cf2b79dca6354c1164695fef342270cc8 /python/ptyprocess
parentbe1482f2295a9c308cff1fe53c913d7db7006514 (diff)
downloadslackbuilds-067cee2dd85635080283ca6ed0cbd25d47c8acb2.tar.gz
python/ptyprocess: Remove python3 bindings.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/ptyprocess')
-rw-r--r--python/ptyprocess/ptyprocess.SlackBuild9
1 files changed, 1 insertions, 8 deletions
diff --git a/python/ptyprocess/ptyprocess.SlackBuild b/python/ptyprocess/ptyprocess.SlackBuild
index 5511c231dc..b5f76dc00e 100644
--- a/python/ptyprocess/ptyprocess.SlackBuild
+++ b/python/ptyprocess/ptyprocess.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for ptyprocess
-# Copyright 2016-2021 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2016-2022 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -81,10 +78,6 @@ find -L . \
python setup.py install --root=$PKG
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
-
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true