summaryrefslogtreecommitdiffstats
path: root/python/psutil/psutil.SlackBuild
diff options
context:
space:
mode:
author Larry Hajali2013-07-13 08:04:17 +0200
committer Robby Workman2013-07-15 00:07:20 +0200
commit97db499365ca64c35ecd2d015380f26bcbb3a734 (patch)
tree0a78f2a9cb49a91f90c18a2a2754c0c8faa7c958 /python/psutil/psutil.SlackBuild
parentff39236caa576a7f59dfef2b61030f457b6caa0b (diff)
downloadslackbuilds-97db499365ca64c35ecd2d015380f26bcbb3a734.tar.gz
python/psutil: Updated for version 1.0.1.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python/psutil/psutil.SlackBuild')
-rw-r--r--python/psutil/psutil.SlackBuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/python/psutil/psutil.SlackBuild b/python/psutil/psutil.SlackBuild
index 659e0ef08a..2c673d0220 100644
--- a/python/psutil/psutil.SlackBuild
+++ b/python/psutil/psutil.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=psutil
-VERSION=${VERSION:-0.7.1}
+VERSION=${VERSION:-1.0.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -57,12 +57,16 @@ find . \
python setup.py install --root=$PKG
+if $(python3 -c 'import os' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- CREDITS HISTORY LICENSE MANIFEST.in PKG-INFO README \
+ CREDITS HISTORY LICENSE MANIFEST.in PKG-INFO README TODO \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild