summaryrefslogtreecommitdiffstats
path: root/python/plaso
diff options
context:
space:
mode:
author Dave Woodfall2021-05-15 17:28:44 +0200
committer Willy Sudiarto Raharjo2021-05-19 13:40:18 +0200
commit994bd188d580e3d55f5ebf89b25860a556794137 (patch)
treea6ea766da1d76dc03be0d1e4cfc0231748733451 /python/plaso
parentfd537802caa44fc37039e76aa832907e5f862af9 (diff)
downloadslackbuilds-994bd188d580e3d55f5ebf89b25860a556794137.tar.gz
python/plaso: Convert python to python2.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/plaso')
-rw-r--r--python/plaso/README21
-rw-r--r--python/plaso/plaso.SlackBuild2
-rw-r--r--python/plaso/plaso.info2
3 files changed, 13 insertions, 12 deletions
diff --git a/python/plaso/README b/python/plaso/README
index 14750f58e3..88138a895b 100644
--- a/python/plaso/README
+++ b/python/plaso/README
@@ -1,13 +1,14 @@
plaso (Forensic Super-Timeline)
-Plaso is the Python based back-end engine used by tools such as log2timeline
-for automatic creation of a super timelines. The goal of log2timeline (and
-thus plaso) is to provide a single tool that can parse various log files and
-forensic artifacts from computers and related systems, such as network equipment
-to produce a single correlated timeline. This timeline can then be easily
-analysed by forensic investigators/analysts, speeding up investigations by
-correlating the vast amount of information found on an average computer system.
+Plaso is the Python based back-end engine used by tools such as
+log2timeline for automatic creation of a super timelines. The goal of
+log2timeline (and thus plaso) is to provide a single tool that can parse
+various log files and forensic artifacts from computers and related
+systems, such as network equipment to produce a single correlated
+timeline. This timeline can then be easily analysed by forensic
+investigators/analysts, speeding up investigations by correlating the
+vast amount of information found on an average computer system.
-Please pay close attention to the build order for plaso and its requirements
-(particularly dfvfs). Read the README files and do NOT rely on automated
-package tools.
+Please pay close attention to the build order for plaso and its
+requirements (particularly dfvfs). Read the README files and do NOT
+rely on automated package tools.
diff --git a/python/plaso/plaso.SlackBuild b/python/plaso/plaso.SlackBuild
index 88294e10d2..4135cd6e8b 100644
--- a/python/plaso/plaso.SlackBuild
+++ b/python/plaso/plaso.SlackBuild
@@ -70,7 +70,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/plaso/plaso.info b/python/plaso/plaso.info
index 9f8ce8d4c1..087f97d5f7 100644
--- a/python/plaso/plaso.info
+++ b/python/plaso/plaso.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://github.com/log2timeline/plaso/releases/download/20190131/plaso
MD5SUM="42402d1a43b7145d34f91bb3d64ef346"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="dfvfs artifacts bencode biplist python-dateutil dfwinreg dotty elasticsearch5 hachoir-metadata python-lz4 pefile psutil pyzmq pytz XlsxWriter libesedb libevt libevtx libfwsi liblnk libmsiecf libolecf libscca yara-python"
+REQUIRES="dfvfs artifacts bencode biplist python2-dateutil dfwinreg dotty elasticsearch5 hachoir-metadata python2-lz4 pefile psutil pyzmq pytz XlsxWriter libesedb libevt libevtx libfwsi liblnk libmsiecf libolecf libscca yara-python"
MAINTAINER="Barry J. Grundy"
EMAIL="bgrundy<at>linuxleo.com"