summaryrefslogtreecommitdiffstats
path: root/python/pip
diff options
context:
space:
mode:
author Audrius Kažukauskas2013-07-28 18:23:38 +0200
committer Erik Hanson2013-10-12 21:38:02 +0200
commitdff549c070950e1e2fafc2664448cfab42a44561 (patch)
treedc3dfdee2f5bd220ad66673184c72d9a27a64dff /python/pip
parent9c25ab7047cb225af86bcf1f9f80d66a58df642f (diff)
downloadslackbuilds-dff549c070950e1e2fafc2664448cfab42a44561.tar.gz
python/pip: Updated for version 1.4.
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'python/pip')
-rw-r--r--python/pip/pip.SlackBuild7
-rw-r--r--python/pip/pip.info6
2 files changed, 9 insertions, 4 deletions
diff --git a/python/pip/pip.SlackBuild b/python/pip/pip.SlackBuild
index 3c201a2630..be450bd618 100644
--- a/python/pip/pip.SlackBuild
+++ b/python/pip/pip.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pip
-VERSION=${VERSION:-1.3.1}
+VERSION=${VERSION:-1.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -57,6 +57,11 @@ find . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
# Add bash completion file.
install -D -m 644 $CWD/pip.sh $PKG/usr/share/bash-completion/completions/pip
diff --git a/python/pip/pip.info b/python/pip/pip.info
index 106ed6ecfa..e3f8c908c4 100644
--- a/python/pip/pip.info
+++ b/python/pip/pip.info
@@ -1,8 +1,8 @@
PRGNAM="pip"
-VERSION="1.3.1"
+VERSION="1.4"
HOMEPAGE="http://www.pip-installer.org/"
-DOWNLOAD="https://pypi.python.org/packages/source/p/pip/pip-1.3.1.tar.gz"
-MD5SUM="cbb27a191cebc58997c4da8513863153"
+DOWNLOAD="https://pypi.python.org/packages/source/p/pip/pip-1.4.tar.gz"
+MD5SUM="ca790be30004937987767eac42cfa44a"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="pysetuptools"