summaryrefslogtreecommitdiffstats
path: root/python/pip
diff options
context:
space:
mode:
author Audrius Kažukauskas2012-12-03 01:55:43 +0100
committer dsomero2012-12-11 22:21:56 +0100
commit547a53cfa5ec1aa7462b6aaf903b0e28d317925e (patch)
tree73c6ba1f3119a59d9c8503715ee30b9eb66be365 /python/pip
parentc481877b149b581a301aab103ec5d0cbfec9768e (diff)
downloadslackbuilds-547a53cfa5ec1aa7462b6aaf903b0e28d317925e.tar.gz
python/pip: Updated for version 1.2.1
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'python/pip')
-rw-r--r--python/pip/pip.SlackBuild25
-rw-r--r--python/pip/pip.info8
-rw-r--r--python/pip/slack-desc12
3 files changed, 32 insertions, 13 deletions
diff --git a/python/pip/pip.SlackBuild b/python/pip/pip.SlackBuild
index 40ab020062..fd82982b62 100644
--- a/python/pip/pip.SlackBuild
+++ b/python/pip/pip.SlackBuild
@@ -1,10 +1,29 @@
#!/bin/sh
# Slackware build script for pip
-# Written by Audrius Kažukauskas <audrius@neutrino.lt>
+
+# Copyright 2012 Audrius Kažukauskas <audrius@neutrino.lt>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pip
-VERSION=${VERSION:-1.0.2}
+VERSION=${VERSION:-1.2.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -39,7 +58,7 @@ find . \
python setup.py install --root=$PKG
# Add bash completion file.
-install -D -m 644 $CWD/pip.sh $PKG/etc/bash_completion.d/pip
+install -D -m 644 $CWD/pip.sh $PKG/usr/share/bash-completion/completions/pip
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a *.txt docs/* $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/python/pip/pip.info b/python/pip/pip.info
index e272c2cb65..26342a63fb 100644
--- a/python/pip/pip.info
+++ b/python/pip/pip.info
@@ -1,10 +1,10 @@
PRGNAM="pip"
-VERSION="1.0.2"
+VERSION="1.2.1"
HOMEPAGE="http://www.pip-installer.org/"
-DOWNLOAD="http://pypi.python.org/packages/source/p/pip/pip-1.0.2.tar.gz"
-MD5SUM="47ec6ff3f6d962696fe08d4c8264ad49"
+DOWNLOAD="http://pypi.python.org/packages/source/p/pip/pip-1.2.1.tar.gz"
+MD5SUM="db8a6d8a4564d3dc7f337ebed67b1a85"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="pysetuptools virtualenv"
+REQUIRES="distribute"
MAINTAINER="Audrius Kažukauskas"
EMAIL="audrius@neutrino.lt"
diff --git a/python/pip/slack-desc b/python/pip/slack-desc
index 0e2c13127e..c4e121a751 100644
--- a/python/pip/slack-desc
+++ b/python/pip/slack-desc
@@ -1,16 +1,16 @@
# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|' on
-# the right side marks the last column you can put a character in. You must make
-# exactly 11 lines for the formatting to be correct. It's also customary to
-# leave one space after the ':'.
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
pip: pip (a better easy_install replacement)
pip:
pip: pip is a replacement for easy_install from pysetuptools.
pip:
-pip: Homepage: http://www.pip-installer.org/
+pip: Homepage: http://www.pip-installer.org/
pip:
pip:
pip: