summaryrefslogtreecommitdiffstats
path: root/python/pikepdf
diff options
context:
space:
mode:
author Rob van Nues2022-04-02 12:30:45 +0200
committer Willy Sudiarto Raharjo2022-04-02 13:19:12 +0200
commit0cdf3e36a2711614a122417a8b1911af08727f4e (patch)
tree2f922a7e5b6eb5d36351f233d37d016d7959ee94 /python/pikepdf
parent82afffce0f8556f2e19e4ba39474199f3c949c09 (diff)
downloadslackbuilds-0cdf3e36a2711614a122417a8b1911af08727f4e.tar.gz
python/pikepdf: Added (Python library).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/pikepdf')
-rw-r--r--python/pikepdf/README10
-rw-r--r--python/pikepdf/pikepdf.SlackBuild95
-rw-r--r--python/pikepdf/pikepdf.info10
-rw-r--r--python/pikepdf/slack-desc19
4 files changed, 134 insertions, 0 deletions
diff --git a/python/pikepdf/README b/python/pikepdf/README
new file mode 100644
index 0000000000..f164e09bb8
--- /dev/null
+++ b/python/pikepdf/README
@@ -0,0 +1,10 @@
+Pikepdf is a Python library for reading and writing PDF files.
+It is based on QPDF, a powerful PDF manipulation and repair
+library. This library is similar to PyPDF2 and pdfrw - it provides
+low level access to PDF features and allows editing and content
+transformation of existing PDFs. Some knowledge of the PDF
+specification may be helpful. It does not have the capability to
+render a PDF to image.
+
+A whole slew of extra dependencies is needed for building the docs.
+To minimize the dependency list, this build script will not do this.
diff --git a/python/pikepdf/pikepdf.SlackBuild b/python/pikepdf/pikepdf.SlackBuild
new file mode 100644
index 0000000000..865705f527
--- /dev/null
+++ b/python/pikepdf/pikepdf.SlackBuild
@@ -0,0 +1,95 @@
+#!/bin/bash
+
+# Slackware build script for pikepdf
+
+# Copyright 2020, 2022 Rob van Nues
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=pikepdf
+VERSION=${VERSION:-5.1.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README.* LICENSE* \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/pikepdf/pikepdf.info b/python/pikepdf/pikepdf.info
new file mode 100644
index 0000000000..0ad8f23664
--- /dev/null
+++ b/python/pikepdf/pikepdf.info
@@ -0,0 +1,10 @@
+PRGNAM="pikepdf"
+VERSION="5.1.1"
+HOMEPAGE="https://github.com/pikepdf/pikepdf"
+DOWNLOAD="https://pypi.python.org/packages/source/p/pikepdf/pikepdf-5.1.1.tar.gz"
+MD5SUM="b3470fa2a0653be8b80554498632e11c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="lxml pybind11 python3-setuptools_scm_git_archive"
+MAINTAINER="Rob van Nues"
+EMAIL="sborg63@disroot.org"
diff --git a/python/pikepdf/slack-desc b/python/pikepdf/slack-desc
new file mode 100644
index 0000000000..8507433dd0
--- /dev/null
+++ b/python/pikepdf/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pikepdf: pikepdf (read write pdf files)
+pikepdf:
+pikepdf: pikepdf is a Python library for reading and writing PDF files.
+pikepdf: pikepdf is based on QPDF, a powerful PDF manipulation and repair
+pikepdf: library
+pikepdf:
+pikepdf:
+pikepdf:
+pikepdf:
+pikepdf:
+pikepdf: