summaryrefslogtreecommitdiffstats
path: root/python/pbr/pbr.SlackBuild
diff options
context:
space:
mode:
author Bogdan Radulescu2019-01-24 12:18:30 +0100
committer Willy Sudiarto Raharjo2019-01-24 12:18:30 +0100
commita5f3eb5226abd848cd1fd1d0c1bb4c160931cc57 (patch)
tree9526f191767121340123d03939e9b8001b73d3f4 /python/pbr/pbr.SlackBuild
parentfcb5d5ddde1c9bfaa68ff69ad1338b8b849720d9 (diff)
downloadslackbuilds-a5f3eb5226abd848cd1fd1d0c1bb4c160931cc57.tar.gz
python/pbr: Updated for version 5.1.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/pbr/pbr.SlackBuild')
-rw-r--r--python/pbr/pbr.SlackBuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/python/pbr/pbr.SlackBuild b/python/pbr/pbr.SlackBuild
index b0165bd457..3dd6193357 100644
--- a/python/pbr/pbr.SlackBuild
+++ b/python/pbr/pbr.SlackBuild
@@ -23,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pbr
-VERSION=${VERSION:-3.1.1}
+VERSION=${VERSION:-5.1.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i586 ;;
+ i?86) ARCH=i686 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -67,12 +67,12 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
+ grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \