summaryrefslogtreecommitdiffstats
path: root/python/nyx
diff options
context:
space:
mode:
author Markus Reichelt2017-11-09 01:24:28 +0100
committer David Spencer2017-11-09 01:24:28 +0100
commit92b8f48ad28719843057a75ebe8e014e2c1be465 (patch)
tree1528578842b66965a355718abf9d8e399f177d60 /python/nyx
parent060c0d6f9244f6a62e58ed549230dc98b19827ec (diff)
downloadslackbuilds-92b8f48ad28719843057a75ebe8e014e2c1be465.tar.gz
python/nyx: Added (Terminal status monitor for Tor).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python/nyx')
-rw-r--r--python/nyx/README7
-rw-r--r--python/nyx/nyx.SlackBuild89
-rw-r--r--python/nyx/nyx.info10
-rw-r--r--python/nyx/slack-desc19
4 files changed, 125 insertions, 0 deletions
diff --git a/python/nyx/README b/python/nyx/README
new file mode 100644
index 0000000000..dbd8ba5ccf
--- /dev/null
+++ b/python/nyx/README
@@ -0,0 +1,7 @@
+Nyx is a command-line monitor for Tor.
+
+With this you can get detailed real-time information about your relay
+such as bandwidth usage, connections, logs, and much more.
+
+Having Tor installed is not required for building.
+The Tor installation does not have to be from SBo.
diff --git a/python/nyx/nyx.SlackBuild b/python/nyx/nyx.SlackBuild
new file mode 100644
index 0000000000..72bc087519
--- /dev/null
+++ b/python/nyx/nyx.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+
+# Slackware build script for nyx
+
+# Copyright 2017 Markus Reichelt, Aachen, DE
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+# Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
+
+PRGNAM=nyx
+VERSION=${VERSION:-2.0.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION $PKG/usr/man/man1
+cp -a web/ LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a nyx.1 $PKG/usr/man/man1
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/nyx/nyx.info b/python/nyx/nyx.info
new file mode 100644
index 0000000000..2a6e813ff7
--- /dev/null
+++ b/python/nyx/nyx.info
@@ -0,0 +1,10 @@
+PRGNAM="nyx"
+VERSION="2.0.4"
+HOMEPAGE="https://nyx.torproject.org/"
+DOWNLOAD="https://pypi.python.org/packages/42/37/85890dae5680f36f5b1c964ad41674ebb8d1186383fbca58f82e76de734c/nyx-2.0.4.tar.gz"
+MD5SUM="14dbd97e35ffcedbe7fd7124a21b3e5e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="stem"
+MAINTAINER="Markus Reichelt"
+EMAIL="slackbuilds@mareichelt.de"
diff --git a/python/nyx/slack-desc b/python/nyx/slack-desc
new file mode 100644
index 0000000000..09a869c561
--- /dev/null
+++ b/python/nyx/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+nyx: nyx (Terminal status monitor for Tor)
+nyx:
+nyx: Nyx is a command-line monitor for Tor. With this you get real-time
+nyx: information about your relay.
+nyx:
+nyx: Homepage: https://nyx.torproject.org/
+nyx:
+nyx:
+nyx:
+nyx:
+nyx: