summaryrefslogtreecommitdiffstats
path: root/python/netifaces/netifaces.SlackBuild
diff options
context:
space:
mode:
author larryhaja2012-09-17 06:36:19 +0200
committer Robby Workman2012-09-18 06:36:12 +0200
commit097c290238caa4d92bf9222af17f64b946fa7349 (patch)
tree053a38ddabf667c5d4707b155da2a9ebae5bda58 /python/netifaces/netifaces.SlackBuild
parent9efd9c7d7f71294e40efb262de9c4da68e27b7c0 (diff)
downloadslackbuilds-097c290238caa4d92bf9222af17f64b946fa7349.tar.gz
python/netifaces: Added (python module for querying network interfaces)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python/netifaces/netifaces.SlackBuild')
-rw-r--r--python/netifaces/netifaces.SlackBuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/python/netifaces/netifaces.SlackBuild b/python/netifaces/netifaces.SlackBuild
new file mode 100644
index 0000000000..a8c33a4650
--- /dev/null
+++ b/python/netifaces/netifaces.SlackBuild
@@ -0,0 +1,53 @@
+#!/bin/sh
+
+# Slackware build script for netifaces
+
+# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+
+PRGNAM=netifaces
+VERSION=${VERSION:-0.8}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}